If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installer removes files and directories that it didn't install

VERIFIED DUPLICATE of bug 69153

Status

SeaMonkey
Installer
--
critical
VERIFIED DUPLICATE of bug 69153
16 years ago
13 years ago

People

(Reporter: leif sawyer, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The mozilla build from 5/15 has an issue with the installer, using the linux 
self-extracting installer.

If the custom option is used, and a directory such as /usr is select (by action 
or accident) the installer will properly install to the /usr directory. 
However, if the user realizes the mistake and reruns the installer (so that it 
may remove the previously installed files) instead of only removing the files 
that the installer installed, the installer removes EVERY FILE AND DIRECTORY 
UNDER THE INSTALL point.  This has serious consequences for those who 
accidently select a directory such as /usr or /usr/local

Fortunately, it only erased my local MP3 collection and my /usr/bin directory 
before I stopped it (it was taking FAR too long..)

Updated

16 years ago
QA Contact: bugzilla → ktrina

Comment 1

16 years ago
duplicate

*** This bug has been marked as a duplicate of 69153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified as a dupe of bug 69153
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.