Closed Bug 1448883 Opened 2 years ago Closed 2 years ago

Cubeb refuses to open a stream if it contains more than 8 channels

Categories

(Core :: Audio/Video: cubeb, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: jya, Assigned: jya)

References

Details

Attachments

(1 file)

cubeb validate_stream_params check that the number of channels do not exceed 8.
https://github.com/kinetiknz/cubeb/blob/789eaaa3b0d77b55e110353972d6713889f510ea/src/cubeb.c#L71

That is preventing media to play that it now handles just fine.
Rank: 15
Priority: -- → P2
Comment on attachment 8962392 [details]
Bug 1448883 - Resync with cubeb 7401fc25a9d.

https://reviewboard.mozilla.org/r/231244/#review236654
Attachment #8962392 - Flags: review?(padenot) → review+
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d465b211dd07
Resync with cubeb 7401fc25a9d. r=padenot
Assignee: nobody → jyavenard
https://hg.mozilla.org/mozilla-central/rev/d465b211dd07
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1232252
You need to log in before you can comment on or make changes to this bug.