View Source occasionally hangs Mozilla while scrolling

RESOLVED WONTFIX

Status

Core Graveyard
View Source
--
critical
RESOLVED WONTFIX
16 years ago
7 years ago

People

(Reporter: Tom Blake, Assigned: Doron Rosenberg (IBM))

Tracking

({hang})

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I've run into this nasty crash on a few ocasions, in a few different versions,
including RC2 for Mac OS 9.

ViewSource displays the source of a long web page which I scroll through,
quickly clicking repeatedly on the down button.  At some point, Mozilla locks
up.  Force Quit yields a non-functioning OS.  (Nothing to do but hit the reset
switch!)

Comment 1

16 years ago
Tblake: Can you reproduce this bug with a latest build? Have you any stacktrace?
Severity: major → critical
Keywords: crash, stackwanted

Comment 2

16 years ago
From reporter via mail:

I just reproduced it with:
Mozilla 1.1a
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a) Gecko/20020611

I'm sorry, I don't have a stacktrace.

I reproduced it by viewing the source of Cringely's latest column,
and "flutter clicking" the mouse on the down button.  (Locked up
tight as a drum.)

Comment 3

15 years ago
WorksForMe using Mac/2002072203. I access a URL, view source, and click the down scroll 
arrow approximately 80 times in rapid succession without crashing.

tblake@binghamton.edu, can you still reproduce this problem using a current build? Does Mozilla 
ever generate a TalkBack report following these crashes? If so, please provide the ID numbers of 
one of these reports.

Also, try to provide the URL of a page that causes your Mozilla to crash.

Comment 4

15 years ago
Reporter: Does this problem still exist (with newer build)?
(Reporter)

Comment 5

15 years ago
It still happens with the 1.2beta.  I'll try the latest nightly on Monday.

If it's of any comfort, I'm now experiencng problems scrolling in normal browser
windows as well.  (Sometimes a crash as described here, most frequently a crash
occurs while I'm dragging the thumb up and down, the scroll bar does not respond
when I click above or below the thumb.)

I'm not experiencing these scrolling problems with any other applications.  I've
tried experimenting with turning off various extensions, quitting various
background applications and the like.  I haven't found a combination yet when
the problems do not occur.

Comment 6

15 years ago
tblake@binghamton.edu, please provide a TalkBack report ID as requested in
comment 3.
(Reporter)

Comment 7

15 years ago
Will do, if I can.  For some reason, after a crash like this, Talkback generally
did not present itself.
(Reporter)

Comment 8

15 years ago
Okay, I just downloaded the latest nightly build, opened http://
www.mozilla.org/releases/, viewed the source, and started rapidly clicking 
the down arrow with my mouse. After several clicks, the ominous watch 
cursor appeared.

At the bottom of the window is the top half of a line of HTML.
Above it, appears a full line of HTML (just a <p>).
Above this, appears the top half line again (apparently just having been 
scrolled.)
Above it appears the <p> and above it everything looks normal.
The watch cursor can be moved by moving the mouse, but my menubar 
clock has stopped, and the system is largely unresponsive (as if there 
was a tight loop.)
I'm able to force-quit Mozilla, and everything appears normal at first, 
however, it soon becomes clear that everything is not normal. (Pressing 
the power key on the keyboard gives me the shut-down dialog, clicking 
Restart with the mouse does not successfully restart. Any open 
applications are unresponsive, and must also be forced to quit.)
The only way out is the reset button.

After the system has rebooted, and Mozilla is relaunched, TalkBack 
doesn't present itself (likely because Mozilla didn't register that anything 
bad had happened, it was just merrily running a loop in an effort to scroll.)

Comment 9

15 years ago
Ah, I see. Technically speaking, tblake@binghamton.edu, what you describe is actually a hang, 
then, not a crash.

Can you reproduce this problem using another Mozilla user profile?
Keywords: crash, stackwanted → hang

Updated

15 years ago
Summary: Mac OS 9 ViewSource occasionally crashes while scrolling → View Source occasionally hangs Mozilla while scrolling
(Reporter)

Comment 10

15 years ago
A new profile, created from scratch, fares no better.

Comment 11

15 years ago
Apologies to Tom, but
Mozilla CFM build is dead.
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.