Capture thumbnails with tracking protection always enabled

RESOLVED FIXED in Firefox 61

Status

()

enhancement
P1
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

(Blocks 1 bug)

Trunk
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

Last year
No description provided.
Assignee

Comment 1

Last year
Forgot to comment ;)

There's concerns of the thumbnail service potentially leaking data leading to bugs like bug 1435432.

There's also issues of thumbnails taking a while to show up.

Turning on tracking protection should speed up thumbnails by reducing the number of connections needed!
See Also: → 1435432
Assignee

Comment 2

Last year
Posted image before / after
These 4 pages do have content removed with tracking protection. It's most noticeable in the 2nd thumbnail where the top empty whitespace is gone and one of the page's image shows a broken image indicator.
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Blocks: 1410920

Comment 4

Last year
mozreview-review
Comment on attachment 8962841 [details]
Bug 1449294 - Capture thumbnails with tracking protection always enabled.

https://reviewboard.mozilla.org/r/231666/#review237688
Attachment #8962841 - Flags: review?(adw) → review+

Comment 5

Last year
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1504ecb0dc31
Capture thumbnails with tracking protection always enabled. r=adw

Comment 6

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/1504ecb0dc31
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61

Comment 7

Last year
mozreview-review
Comment on attachment 8962841 [details]
Bug 1449294 - Capture thumbnails with tracking protection always enabled.

https://reviewboard.mozilla.org/r/231666/#review241550

::: toolkit/components/thumbnails/content/backgroundPageThumbsContent.js:43
(Diff revision 1)
>        priority = Ci.nsISupportsPriority.PRIORITY_LOWEST;
>  
>      docShell.allowMedia = false;
>      docShell.allowPlugins = false;
>      docShell.allowContentRetargeting = false;
>      let defaultFlags = Ci.nsIRequest.LOAD_ANONYMOUS |

You should also add `nsIChannel::LOAD_CLASSIFY_URI` to that list so that Activity Stream thumbnails are automatically run through Safe Browsing.

This will avoid taking screenshots of phishing or malware sites.
Assignee

Updated

Last year
See Also: → 1453448
Assignee

Updated

Last year
Duplicate of this bug: 1410920
You need to log in before you can comment on or make changes to this bug.