Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: anba, Assigned: anba)

Tracking

Trunk
mozilla61
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr52 fixed, firefox60 fixed, firefox61 fixed)

Details

Attachments

(3 attachments)

Priority: -- → P3
This seems time-sensitive, so I bumped it to P1.

anba, What work is involved here? Do we have to coordinate with the rest of Gecko?
Flags: needinfo?(andrebargull)
Priority: P3 → P2
Priority: P2 → P1
(Assignee)

Comment 2

a year ago
(In reply to Jason Orendorff [:jorendorff] from comment #1)
> This seems time-sensitive, so I bumped it to P1.

Ignoring some fixes for past dates, tzdata2018d changes only the data for three time zones:
- Antarctica/Casey switches from +11 to +08. (Probably not too many Firefox users at this science station in Antarctica.)
- Asia/Gaza and Asia/Hebron started DST on March 24 instead of March 31. (This info was relayed way too late to the tzinfo maintainers, so Palestinian users potentially had to struggle with wrong computer clocks this week.)


> anba, What work is involved here?

Two scripts need to be run (one to update the ICU data blob and another one to update some SpiderMonkey tests):

  cd intl
  ./update-tzdata.sh -e $ICU60_BUILD_DIR/bin/icupkg 2018d
  cd ../js/src/builtin/intl/
  ./make_intl_data.py tzdata


> Do we have to coordinate with the rest of Gecko?

No that I know of.
Flags: needinfo?(andrebargull)
(Assignee)

Comment 3

a year ago
Update to tzdata2018d.
Attachment #8963674 - Flags: review?(jwalden+bmo)
Comment on attachment 8963674 [details] [diff] [review]
bug1449574.patch

Review of attachment 8963674 [details] [diff] [review]:
-----------------------------------------------------------------

Joy.
Attachment #8963674 - Flags: review?(jwalden+bmo) → review+

Comment 6

a year ago
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c21d6cad94c
Update tzdata in ICU data files to 2018d. r=Waldo
Keywords: checkin-needed

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3c21d6cad94c
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
(Assignee)

Comment 8

a year ago
Backport for Beta. (Needs a different patch because Beta uses ICU60.)
Attachment #8964913 - Flags: review?(jwalden+bmo)
(Assignee)

Comment 9

a year ago
Backport for ESR52. (Needs a different patch because ESR52 uses ICU58.)
Attachment #8964914 - Flags: review?(jwalden+bmo)
Attachment #8964913 - Flags: review?(jwalden+bmo) → review+
Attachment #8964914 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 10

a year ago
Comment on attachment 8964913 [details] [diff] [review]
bug1449574-beta.patch

Approval Request Comment
[Feature/Bug causing the regression]: N/A

[User impact if declined]:
Wrong or inconsistent time zone data when calling methods from Intl.DateTimeFormat or methods internally using Intl.DateTimeFormat (that means Date.prototype.toLocale(Date|Time)String()). Inconsistencies are possible when the OS already uses the current tzdata release (tzdata 2018d), but our internal ICU version still uses tzdata 2018c. 
Based on the release notes for tzdata 2018d <https://mm.icann.org/pipermail/tz-announce/2018-March/000049.html>, the update is of special interest for users in Palestine (starting this year, DST now begins on the first Saturday after 21st March). And possibly for researchers at the Casey Station in Antarctica (time zone changed from +11 to +08).

[Is this code covered by automated tests?]:
Yes.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It only updates time zone data files.

[String changes made/needed]:
No.
Attachment #8964913 - Flags: approval-mozilla-beta?
(Assignee)

Comment 11

a year ago
Comment on attachment 8964914 [details] [diff] [review]
bug1449574-esr52.patch

[Approval Request Comment]

If this is not a sec:{high,crit} bug, please state case for ESR consideration:

User impact if declined: 
See comment #10.

Fix Landed on Version:
Firefox 61; Firefox 60 see comment #10.

Risk to taking this patch (and alternatives if risky): 
See comment #10.

String or UUID changes made by this patch: 
No.
Attachment #8964914 - Flags: approval-mozilla-esr52?
Comment on attachment 8964913 [details] [diff] [review]
bug1449574-beta.patch

Timezone data update needed to avoid returning incorrect results for various methods. Approved for 60.0b11 and ESR 52.8.0.
Attachment #8964913 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8964914 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.