Closed Bug 1450249 Opened 3 years ago Closed 3 years ago

blob-invalidation: Round the bounds

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Comment on attachment 8963932 [details]
Bug 1450249. blob-invalidation: Round the bounds.

https://reviewboard.mozilla.org/r/232770/#review238480

::: gfx/layers/wr/WebRenderCommandBuilder.cpp:543
(Diff revision 1)
> +    LayoutDeviceIntPoint offset = RoundedToInt(bounds.TopLeft());
> +    bounds = LayoutDeviceRect(offset, LayoutDeviceSize(RoundedToInt(bounds).Size()));

How is this different from
bounds = LayoutDeviceRect(RoundedToInt(bounds));
?
Assignee: nobody → jmuizelaar
Priority: -- → P1
Duplicate of this bug: 1450126
The rounding of Rectangles is different https://searchfox.org/mozilla-central/source/gfx/2d/BaseRect.h#474

The rectangle rounding might be more correct, but I'd like to match the existing code for now.
I'm not sure I understand. Both of these round the edges. Can you give me an example where the two would be different?
I misread the original code as RoundedToInt(bounds.Size()))
Comment on attachment 8963932 [details]
Bug 1450249. blob-invalidation: Round the bounds.

https://reviewboard.mozilla.org/r/232770/#review239010
Attachment #8963932 - Flags: review?(mstange) → review+
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/763909764666
blob-invalidation: Round the bounds. r=mstange
https://hg.mozilla.org/mozilla-central/rev/763909764666
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.