Closed Bug 1450471 Opened 2 years ago Closed 2 years ago

Font Enworsening

Categories

(Core :: Graphics: Text, defect)

52 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: piotrunio-2004, Unassigned)

Details

Attachments

(1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20180322140748

Steps to reproduce:

See https://support.mozilla.org/questions/1196279 and http://superscriptsubscripttest.bitballoon.com/


Actual results:

1. changing the font height, causing incorrect font ratio and gaps in selection 2. changing the space width, ruining the monospace beauty 3. rendering characters high or low in small size when HTML superscript or subscript is used 4. inconsistent character squishing in PDF files, ruining the monospace beauty and thickness 5. modifying the font spacing, causing incorrect font ratio 6. in case of bitmap fonts (supported on XP but not 10) the text is shifted pixel left, which may be cut off and is not synced with selection and current character guide line 


Expected results:

What Firefox should do? (the numbers correspond to the numbers above) 1. preserve font height 2. preserve character width 3. allow customization of this and/or use the Unicode superscript/subscript font characters depending on character availability 4. preserve character width and stretch 5. preserve character width 6. preserve character phase 7. allow bitmap fonts in all Windows versions, just like Notepad does so with no problem 8. to compensate for fonts which have characters mapped to wrong characters due to 256 character limit on .fon fonts, allow a character replacement table (including superscripts/subscripts) 9. allow formatting replacement table (for example red text color instead of bold, etc.) 10. allow a size replacement table, in case a font looks ugly on some/most sizes 11. allow color customization more than ever (like grayed out text being red instead of darkened) 12. fix the bug where text and background color override doesn't work properly on high contrast, instead using your favorite color scheme regardless of settings 13. allow a "Red Detection" feature, which detects a red text color (not link color) set in webpage and allows you to choose a custom color for it 14. allow a "Magnifying Glass" feature, which allows you to see a small area without color or font overrides (with a hotkey)
Attachment #8964124 - Attachment description: Test page for <sup> and <sub> tags being treated horribly wrong, also in http://superscriptsubscripttest.bitballoon.com/ → Test page for <sup> and <sub> tags being treated horribly wrong, please see http://superscriptsubscripttest.bitballoon.com/ instead as it also adds emojis to the mix
Attachment #8964124 - Attachment is obsolete: true
Not sure what you are saying here but I do see the same output on Chrome, Edge, and Firefox.
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Look at "Actual results". The 1, 2 and 5 are the result of the underlying HTML not being disablable. The 3 just happens to be the mistake all "modern browsers" do, when they should actually render the superscripts and subscripts from Unicode, and use FFFD when it isn't available in Unicode. The 4 and 6 are specific to Firefox.
The expectations suggested here are not appropriate for the web platform.

Elements <sup> and <sub> apply a visual super- or subscripting effect (reduced font size, baseline offset) to any text content; they are not restricted to working on characters for which a pre-scripted Unicode character exists (and is supported in the font). This is by design, and changing it would break lots of web content.

Why should the browser be expected to render emoji characters as monochrome when the system's default emoji font is colored?

Of course the width of spaces (mentioned in the SUMO issue) will vary if text is justified, regardless of whether the font is "monospaced". How else is the browser expected to achieve full justification? That has nothing to do with "modifying" the font; it's the page designer's choice regarding how the font is used.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
I don't want a super- or subscripting _effect_, which looks awful and is a font modification. I want real superscripts and subscripts, which is the way font designer made them.

"This is by design, and changing it would break lots of web content." then make it an optional option.

"Why should the browser be expected to render emoji characters as monochrome when the system's default emoji font is colored?" That's how Notepad does this.

"How else is the browser expected to achieve full justification?" By allowing an option to disable justification!

"That has nothing to do with "modifying" the font;" The space has changed width, therefore the fonts are modified.

"it's the page designer's choice regarding how the font is used." However, Firefox allows overriding a font. The thing is that Firefox will then modify whatever font is chosen. And some fonts are illegal to modify.

Please allow options to disable any form of Font Enworsening. That means Firefox will grab superscripts, subscripts and small capitals from Unicode when there are tags (using FFFD when not in Unicode), ignore justification, spacing and line height, render PDFs correctly with font and color override and render bitmap fonts correctly when the options are enabled. It will not harm any user experience because these options would be optional!
You need to log in before you can comment on or make changes to this bug.