Closed Bug 1450541 Opened 2 years ago Closed 2 years ago

Values of non-enumerable symbol properties are not shown

Categories

(DevTools :: Console, defect)

57 Branch
defect
Not set

Tracking

(firefox-esr52 unaffected, firefox59 wontfix, firefox60 verified, firefox61 verified)

VERIFIED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- wontfix
firefox60 --- verified
firefox61 --- verified

People

(Reporter: Oriol, Assigned: Oriol)

References

Details

(Keywords: regression)

Attachments

(1 file)

Run this:

    inspect(Object.defineProperty({}, Symbol(), {value: 1}))

Result:

    ▼ {…}
    |   Symbol(): undefined
    | ▶ <prototype>: Object { … }

Expected:

    ▼ {…}
    |   Symbol(): 1
    | ▶ <prototype>: Object { … }

This was regressed in https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7bda9cc7b79882ff5986a1e6192f64fe2aca1bb5&tochange=8b0058e2a4a8a123e09470b7ee975963be88a158 because the object inspector used another request protocol for symbols, but it's a server problem (https://searchfox.org/mozilla-central/rev/0e8eb01368600eb552dd558c83c64a3b6a0b89b8/devtools/server/actors/object.js#1215)
Comment on attachment 8964181 [details]
Bug 1450541 - Show values of non-enumerable symbol properties in object inspector

https://reviewboard.mozilla.org/r/232928/#review238682

Nice and simple, with a test, that's perfect Oriol. Thanks a lot !
Attachment #8964181 - Flags: review?(nchevobbe) → review+
You’re welcome!
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/efe04571107d
Show values of non-enumerable symbol properties in object inspector r=nchevobbe
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/efe04571107d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Is this worth backport consideration or can it ride the 61 train to release?
Flags: needinfo?(oriol-bugzilla)
Flags: in-testsuite+
Comment on attachment 8964181 [details]
Bug 1450541 - Show values of non-enumerable symbol properties in object inspector

Approval Request Comment
[Feature/Bug causing the regression]: it's noticeable since bug 1399460, but the problem existed since bug 1392614.
[User impact if declined]: the console will show undefined instead of the value of non-enumerable symbol properties when inspecting an object.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: I have manually verified it in Nightly.
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: not risky
[Why is the change risky/not risky?]: trivial fix, it makes the symbol iterator stop passing onlyEnumerable=true parameter to _propertyDescriptor. Therefore non-enumerable descriptors are no longer ignored.
[String changes made/needed]: none
Flags: needinfo?(oriol-bugzilla)
Attachment #8964181 - Flags: approval-mozilla-beta?
Comment on attachment 8964181 [details]
Bug 1450541 - Show values of non-enumerable symbol properties in object inspector

trivial devtools console bug fix, approved for 60.0b14
Attachment #8964181 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I managed to reproduce this issue on Firefox 59.0.2, under Windows 10x64.
The issue is no longer reproducible on Firefox 60.0b14, or on Firefox 61.0a1 (2018-04-20).
Tests were executed under Windows 10x64, Ubuntu 16.04x64, macOS 10.10.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.