Closed Bug 1450689 Opened 2 years ago Closed 2 years ago

Firefox 59.0.2 When viewing a pdf, no longer a "download" icon in upper right near the "print" icon

Categories

(Firefox :: PDF Viewer, defect)

61 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- verified
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- verified
firefox62 --- verified

People

(Reporter: joelfishman.pmet1, Assigned: RyanVM)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

Firefox 59.0.2 for Win10. Open a pdf either from internet. Dialog box asks "download or view in Firefox". Choose "view in Firefox"


Actual results:

Pdf appears in new tab. Icons in upper right for Full Screen, Print, and Open in New Tab(?), but NO download icon


Expected results:

There was always a download icon so that you didn't need to go to the website twice in order to get a copy after viewing. Note that opening a local pdf also has same result.
Only happens when you get the pop-up box asking about file handling. Where website asks to view or download, selecting view DOES show the download icon. In other words, when using the pop-up box asking about file handling, selecting "view in Firefox" results in the file being treated as local, and thus no download icon.

Having now seen this distinction, I can't say whether or not this is new behavior.
I also get your Actual results on Windows 10 64bit with Firefox 59.0.2(2018-04-26) and Nightly 61.0a1 (2018-04-05) (64-bit) .
 
In my view, that is also the expected result for me. We might have different settings, so could you provide the following additional details:

- the website example where you get the behavior? 
- what is the setting for: Hamburger Menu/ Applications / 'Portable Document Format (PDF)' - (default is preview)
- when you say download icon, do you refer to the Adobe Download icon or the Firefox Download icon: would be best if you could add a screenshot
Flags: needinfo?(joelfishman.pmet1)
Hi joelfishman.pmet1,
I tested this and here are my steps:

Please test this issue after following this steps:
1. Right click on the "Tab bar"
2. Select "Customize"
3. Click on the "Download icon" from the top right corner
4. Uncheck the "Auto-hide" option

Can you please retest this issue following the steps mentioned above? Thanks
Flags: needinfo?(joelfishman.pmet1)
Sorry, I think I misunderstood the bug specification of the "Download icon" placement. I thought you mean "Download icon" of the browser instead of the Adobe Download icon. Can you please clarify this?
Also I verified the download button near the print button from the PDF view on Windows 10 X64 with Firefox 61.0a1(2018-04-22) and I cannot reproduce it.
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Flags: needinfo?(joelfishman.pmet1)
OS: Unspecified → Windows 10
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to Daniel_A from comment #4)
> Sorry, I think I misunderstood the bug specification of the "Download icon"
> placement. I thought you mean "Download icon" of the browser instead of the
> Adobe Download icon. Can you please clarify this?
> Also I verified the download button near the print button from the PDF view
> on Windows 10 X64 with Firefox 61.0a1(2018-04-22) and I cannot reproduce it.

First, in reply to your advise on un-hiding the download icon in the tab bar, I have never had such an icon in the tab bar, I don't see one under "customize", and so have no option to modify it.

Second, I am referring to the built-in, mozilla supplied PDF viewer window, which has its own sub-frame which usually contains 4 icons in the upper right corner. These are (from left to right), Copy/Open in new window, Download, Print, Switch to Presentation Mode. Here is a url with what I consider "normal" behavior (i.e. all 4 icons)

https://regmedia.co.uk/2018/02/02/nunes-fisa-memo.pdf

The counter example can be seen when opening a PDF on the local file system. If you've selected Firefox as the default app for PDF, you double click the local PDF, and it opens in Firefox, but without the Download icon in the PDF sub-frame. This makes sense, because why would one want to download something that's already on the local file system? The problem is that you also get this behavior with certain remote PDF's. I see this consistently on sites where the link to get the PDF generates a browser pop-up window asking for which app to use to view the file (with the default choice being Firefox, so it knows it's already set to default there). I also see this where the website generates its own pop-up asking if you want to view or download. If you choose view, a new tab appears with the PDF, but (sometimes) no download icon. This is consistent behavior with T-Mobile's site when accessing personal statements, and EZPass in the same circumstance. This is NOT the behavior of earlier Firefox builds, which always showed the download icon.

Why does this matter? When working properly, you can view a PDF and save it locally from one screen without having to go back and access the PDF a second time in order to save it. This is non-trivial, because on some of these sites the PDF is being built on the fly, so it means waiting around twice for the same file to be generated.
Flags: needinfo?(joelfishman.pmet1)
I verified this issue on Windows 10 x64 with Firefox 61.0a1(2018-04-24) and I cannot reproduce it. Please see the attached file with my results.
(In reply to Daniel_A from comment #7)
> I verified this issue on Windows 10 x64 with Firefox 61.0a1(2018-04-24) and
> I cannot reproduce it. Please see the attached file with my results.

Did you not read my long-winded post? The URL I gave you is one that WORKS PROPERLY, so of course it doesn't show the bug. Here is a URL that causes the open-or-download pop-up. Click the "Download" button on the page, and you'll get the pop-up. If you choose "Open in Firefox" rather than download, you do NOT get a download icon in the PDF sub-frame.

https://www.microsoft.com/en-us/download/details.aspx?id=56846
Thanks for the clear steps. 
Based on Comment8 I manage to reproduced this issue on Windows 10 64bit with FF 61.0a1 (2018-05-02) (64-bit).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 59 Branch → 61 Branch
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1464550
OS: Windows 10 → Unspecified
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Attached patch beta backportSplinter Review
Generated by applying the upstream PR and regenerating the mozcentral package.
Attachment #8982505 - Flags: review?(bdahl)
Attached patch esr60 backportSplinter Review
Same as the Beta patch
Attachment #8982506 - Flags: review?(bdahl)
Attachment #8982505 - Flags: review?(bdahl) → review+
Attachment #8982506 - Flags: review?(bdahl) → review+
Assignee: nobody → ryanvm
Comment on attachment 8982505 [details] [diff] [review]
beta backport

Fixes a confusing PDF viewer UX issue. Approved for 61.0b11 and ESR 60.1.
Attachment #8982505 - Flags: approval-mozilla-beta+
Attachment #8982506 - Flags: approval-mozilla-esr60+
Build ID: 20180604143143
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Verified as fixed on Firefox Nightly 62.0a1 and Firefox 61.0b11 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Setting the qe-verify+ flag for the ESR60 verification.
Flags: qe-verify+
Build ID: 20180606023959
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Verified as fixed on Firefox ESR on a build from "https://treeherder.mozilla.org/#/jobs?repo=mozilla-esr60&fromchange=efbcc205a0d3562691bf62bb0cb55bb7e891e8ff&selectedJob=182024831" on Windows 10 x 64, Windows 7 x32, Mac OS X 10.12 and Ubuntu 16.04 x64.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.