Closed Bug 1450700 Opened 3 years ago Closed 3 years ago

[css-grid] Grid item with percentage paddings/marings makes row to size incorrectly

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1434478

People

(Reporter: rego, Assigned: mats)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:


Open the attached example, a grid container with "grid-template-columns: 100px" and an item with "padding-top: 50%".


Actual results:


The grid has a row of 120px, the item has a padding of 50px.


Expected results:


The row should have 60px, the padding of the item is right.

There are similar issues with margin too (though the size of the row varies).

You can check these WPT tests too, to reproduce the problem:
* http://w3c-test.org/css/css-grid/grid-items/grid-items-percentage-margins-001.html
* http://w3c-test.org/css/css-grid/grid-items/grid-items-percentage-paddings-001.html
Component: Untriaged → Layout
Product: Firefox → Core
Thanks for your report.  The current Nightly build now pass all those tests.
I'm pretty sure it was fixed by bug 1434478 so duping to that bug.
Assignee: nobody → mats
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1434478
You need to log in before you can comment on or make changes to this bug.