Closed Bug 1450977 Opened 4 years ago Closed 2 years ago

Remove devtools/server/actors/object/long-string.js

Categories

(DevTools :: General, enhancement, P3)

enhancement

Tracking

(firefox61 wontfix, firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox61 --- wontfix
firefox72 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In Bug 1449188, we plan to move the longString actor used by the object actor in its own file (at devtools/server/actors/object/long-string.js).
But we already have a newer, protocol.js based longString actor: https://searchfox.org/mozilla-central/rev/f5fb323246bf22a3a3b4185882a1c5d8a2c02996/devtools/server/actors/string.js 

We should delete devtools/server/actors/object/long-string.js and use the newest longString actor from actors/string.js
Priority: -- → P3
Here I need to replace all paths of 'long-string.js' with new path of 'string.js' in these files?
https://dxr.mozilla.org/mozilla-central/search?q=long-string.js&redirect=false

or any thing else?

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #0)
> In Bug 1449188, we plan to move the longString actor used by the object
> actor in its own file (at devtools/server/actors/object/long-string.js).
> But we already have a newer, protocol.js based longString actor:
> https://searchfox.org/mozilla-central/rev/
> f5fb323246bf22a3a3b4185882a1c5d8a2c02996/devtools/server/actors/string.js 
> 
> We should delete devtools/server/actors/object/long-string.js and use the
> newest longString actor from actors/string.js
Flags: needinfo?(nchevobbe)
Bug 1449162 will make use of the protocol.js based string actor for network events.  After that lands, there will still be some usages left for other non-network console code paths.

It might be easiest to first wait for that work to land, as it provides an example of what the conversion here might look like.
Depends on: 1449162
(In reply to Manish Kumar from comment #1)
> Here I need to replace all paths of 'long-string.js' with new path of
> 'string.js' in these files?
> https://dxr.mozilla.org/mozilla-central/search?q=long-string.
> js&redirect=false
> 
> or any thing else?
> 

It's a bit more complex I think. We need to make sure that the lngString actor is created as it should, and see if we need to change any client call.
Flags: needinfo?(nchevobbe)
Product: Firefox → DevTools
Duplicate of this bug: 1451019
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED

A test is removed as well as it tested this specific actor,
and we have tests for the new LongStringActor.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7999647b29ef
Remove old LongStringActor. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.