Closed Bug 1451102 Opened 3 years ago Closed 3 years ago

Get layout/reftests/bugs/614272-1.svg passing with blob invalidation

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: jrmuizel, Assigned: Gankra)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
Blocks: 1450015
Assignee: nobody → a.beingessner
Blocks: 1451305
Blocks: 1451422
No longer blocks: 1451305
Tweaked to go back to scaling the DT
Attachment #8965852 - Attachment is obsolete: true
Attachment #8965852 - Flags: review?(jmuizelaar)
Attachment #8965857 - Flags: review?(jmuizelaar)
Attachment #8965857 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8965857 [details] [diff] [review]
Bug 1451102 - roundout blobimage bounds and use that result consistently.

Whoops this needed to be squashed with its predecessor!
Attachment #8965857 - Attachment is obsolete: true
Comment on attachment 8965923 [details]
Bug 1451102 - roundout blobimage bounds and use that result consistently.

https://reviewboard.mozilla.org/r/234732/#review240402
Attachment #8965923 - Flags: review?(jmuizelaar) → review+
It looks like this makes some things better and some things worse. There's a bunch of new failures in R6 that all look a similar cause.

It also looks like a bunch of tests might have been regressed by bug 1451761
As far as I can tell, the only regression is this huge pile of smil tests which are now losing pixels on the bottom/right: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/YOaz9iU-Q-ygA7xa3dLaJA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

Just now taking a look into it, but if I had to guess our division trick is inadequate.

Sadly, I haven't been able to reproduce this regression locally.
After some investigation it appears all the regressions we're seeing here are intermittents caused by the bugs in Jeff's dirtyrect stuff. So we should be able to just land this now, and the issues will go away when that gets fixed.
Keywords: checkin-needed
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d3c654a2185f
roundout blobimage bounds and use that result consistently. r=jrmuizel
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d3c654a2185f
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.