Closed Bug 1451125 Opened 5 years ago Closed 5 years ago

Allow a disabled extension to be installed again

Categories

(Toolkit :: Add-ons Manager, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1313298
Tracking Status
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: andrew.lord, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

1. Extension gets disabled (many scenarios in which this can occur, doesn't matter)
2. User tries to install extension again
3. Browser prompts are shown (Allow, then Add), user accepts
4. Nothing happens


Actual results:

Extension is not re-installed or enabled, nothing happens and there is no communication to the user


Expected results:

Ideally, behave similar to Chrome and simply re-enable the extension since it's already installed.
Additional communication that the extension is already installed but disabled might help as well.
Seems I found a similar bug, also still open: https://bugzilla.mozilla.org/show_bug.cgi?id=1313298
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0 (20180406103336)

I have tested this report on Windwos 10 using latest Nightly and Fx release builds and I've managed to reproduce it.
When extension is disabled for any reason, re-installing it does not enable it. 

I`m able to manually enable it, but I would expect after installing it to be enabled by default.

I've used the following extension to reproduce the issue: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/
Status: UNCONFIRMED → NEW
Component: Untriaged → Add-ons Manager
Ever confirmed: true
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.