Closed Bug 1451203 Opened 3 years ago Closed 3 years ago

tsvgx regression

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1416652

People

(Reporter: jrmuizel, Unassigned)

References

(Blocks 1 open bug)

Details

Depends on: 1451761
A current profile on mac with my current patches:
https://perfht.ml/2GY8XYk
One reason we'll be worse than current Firefox is because we invalidate a rect, while Firefox invalidates a region. This test case gets hurt because of that.
Still a large regression. This regression is bigger than I'd expect which suggests there's something unusual going on. We should try to get profiles/reproduce locally.
Here's a profile https://perfht.ml/2Ju1RrT

It looks like we're blocked on vsync whilst asking to composite at a fantastic rate.
Actually we don't seem blocked on vsync in the profile above, but are in this profile: https://perfht.ml/2HuRNOV

I don't know why this would be different.
this got way worse, tsvgx is up to 220% on windows, 130% on other platforms
Let's use bug 1416652 for tracking the tsvgx regression.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1416652
You need to log in before you can comment on or make changes to this bug.