Closed Bug 1451377 Opened 3 years ago Closed 3 years ago

new Date().getMilliseconds() always returns an even number in version 59+

Categories

(Core :: JavaScript Engine, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1440863

People

(Reporter: rynjwssl, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3387.0 Safari/537.36

Steps to reproduce:

In the devTools console tab I entered the following code:
var d = new Date();
console.log(d.getMilliseconds());


Actual results:

This always returned an even number no matter how many times it is run.


Expected results:

This should always return the current millisecond count, and should not be limited to even numbers.
Enter about:config?filter=privacy.resistFingerprinting into the location bar. In the search results, what's the value of privacy.resistFingerprinting?
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: Untriaged → JavaScript Engine
Flags: needinfo?(rynjwssl)
Product: Firefox → Core
This is caused by Spectre timer mitigations: in 59 it has a resolution of 2 ms. In 60+ we will change this to <= 1 ms with jitter.
Flags: needinfo?(rynjwssl)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1440863
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
20180405104009

(In reply to Jan de Mooij [:jandem] from comment #2)
> In 60+ we will change this to <= 1 ms with jitter.

Has this already happened? Going through the STR 3 times, the third value returned was 27, hence my question at comment 1. Having tried it again now, the first result was 631.
(In reply to Gingerbread Man from comment #4)
> > In 60+ we will change this to <= 1 ms with jitter.
> 
> Has this already happened? Going through the STR 3 times, the third value
> returned was 27, hence my question at comment 1. Having tried it again now,
> the first result was 631.

See bug 1448869.
You need to log in before you can comment on or make changes to this bug.