JSTerm autocomplete input is confused when there's a new line after the caret position

RESOLVED DUPLICATE of bug 1479521

Status

defect
RESOLVED DUPLICATE of bug 1479521
Last year
11 months ago

People

(Reporter: nchevobbe, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(firefox61 affected)

Details

Attachments

(1 attachment)

Posted image JSTerm issue
**Steps to reproduce**
1. Open the webconsole
2. In the input, paste the following: 
```js
{
window
```
3. Hit <kbd>Enter</kbd> **twice**
4. Hit <kbd>ArrowLeft</kbd> once to get to the penultimate line
5. Enter `.add` 


**Expected results**

There is an autocomplete text (in grey), completing the input to `.addEventListener`

**Actual results**

I can't see the completion node (see attachment)

---
Reporter

Updated

Last year
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [boogaloo-mvp]

Updated

Last year
Product: Firefox → DevTools
Reporter

Comment 1

11 months ago
Will be handled in Bug 1479521
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479521

Updated

11 months ago
Priority: P2 → --
Whiteboard: [boogaloo-mvp]
You need to log in before you can comment on or make changes to this bug.