deactivated "personal" toolbar tab shows up in javascript activated pop-ups

VERIFIED DUPLICATE of bug 57022

Status

()

VERIFIED DUPLICATE of bug 57022
17 years ago
10 years ago

People

(Reporter: chirney1, Assigned: hyatt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (release candidate 2)
BuildID:    2002051006

This is a minor bug that affects pages that use a javascript to pop-open the 
main page (which might be entirely flash based for example).  In mozilla, you 
can disable the bottom-most toolbar (the one that contains "home" "bookmarks" 
and some mozilla related links) by clicking on the little tab and it leaves a 
little minimized tab at the top.  If the bottom-most menu is visible when you 
go to the pages I've mentioned, there is no bug.  If however the bottom menu is 
minimized, that "minimized state" tab at the top of the main browser window 
will also appear at the top of the pop up window (even if you've specified in 
the javascript that there should be no menu at all).  This is annoying because 
if you click on the little tab in the pop up, it will make it disappear but 
leave an empty space at the bottom of the pop up.  I ran into this while 
developping a similar page myself.

Reproducible: Always
Steps to Reproduce:
0.startup mozilla fresh
1.minimize the bottom-most toolbar ("home", "bookmarks", mozilla links) at the 
top of the browser window so only a small tab remains
2.go to www.gamecube.com or www.quannum.com (and enter site)
3.notice the tab at the top of the pop up
4.click on the tab
5.notice how it disappears but leaves a blank space at the bottom

Actual Results:  there is a tab at the top of the pop-up window
if you click on it, it disappears but leaves a blank space at the bottom

Expected Results: should not have displayed a tab of any sort in the pop-up 
window.  (it is specified in the javascript that there should be no menus or 
toolbars at all)

happens in both default themes.

really love the browser

Comment 1

17 years ago
Oh, man. I thought we had fixed this, but nope. Thanks for pointing this out.
I think we should look into a fix for this.

*** This bug has been marked as a duplicate of 57022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.