Closed Bug 1451689 Opened 2 years ago Closed 3 months ago

SeaMonkey Nightly linux builds not generated

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set
normal

Tracking

(seamonkey2.58 affected)

RESOLVED WONTFIX
Tracking Status
seamonkey2.58 --- affected

People

(Reporter: ray, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.7) Gecko/20100101 Firefox/52.7
Build ID: 20180327210750




Expected results:

SeaMonkey Nightly linux builds since 20th March have been failing for trivial reasons.

Firstly because the build can't find llvm-config for a stylo build or recognize the --disable-stylo option, and now because the gcc version is too old.

Any chance that these issues can be fixed.

I've recently built a version of SM 2.58a1 which won't launch URLs so it would be useful to have a Nightly build to compare it to.
It is not that easy to fix. mozilla-central now needs gcc 6. We need to upgrade the builders. 

The url issue is probably because of bug 1451078. ui should be broken by now too because of grippy and some other xbl removals whcih we need to fix too. We are trying to get esr 60 (currently in beta) in shape first. Don't hold your breath for any fixes unless you do them yourself :)

FRG
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Build Config
Version: SeaMonkey 2.58 Branch → Trunk
Summary: SeaMonkey Nightly linux builds → SeaMonkey Nightly linux builds not generated
Thanks for that information - I'll give SeaMonkey nightly builds a miss for now. Fixes are beyond my capabilities.

Just to clarify the use of gcc6, though.

I based my build of SeaMonkey 2.58 on the revisions of the nightly build of 2018-04-03-00-30-01, comm-central-trunk-linux64-nightly-build421, that is:
mozilla-central/445255800255
comm-central/c79eb711d4d4

The nightly build failed with
ERROR: Only GCC 6.1 or newer is supported (found version 4.9.4).

but both my Firefox and SeaMonkey builds completed using gcc 5.4.0


Is gcc6 a requirement for the nightly build environment or for Firefox, in which case am I missing something?
It is my understanding that all affected builds now require gcc 6.1. See Bug 1444274

Maybe only the configure failed but if you do a clobber build or remove the object dir it should fail completly now for SeaMonkey, Firefox and Thunderbird.
Mhm, sometimes there are problems with builds of SM-Trunk on Linux. Nevertheless, here are my successfully finished builds of April 2018:

hafi@i5-64 ~/seam $ ls -1d 1804*
1804010323
1804020708
1804030023
1804040008
1804050051
1804052237
1804062312
1804072257
1804082302
1804092259
1804102303
1804112026
1804130003
1804132148
1804150005
1804160016
1804170026
1804180042
1804202047
1804220010
1804230032
1804240009

None of them usable, though. *g*

The old infra is gone. The new one currently based on Cent OS 7 can build the (completely useless for now) comm-central SeaMonkey.
In time new nightly builds will be set up.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.