Closed Bug 1451987 Opened 2 years ago Closed Last year

Tab character in developer tools

Categories

(DevTools :: Console, defect)

x86_64
All
defect
Not set

Tracking

(firefox60 affected, firefox61 affected)

RESOLVED DUPLICATE of bug 1472161
Tracking Status
firefox60 --- affected
firefox61 --- affected

People

(Reporter: brandon, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:

1. Open the developer tools
2. Open the console
3. Try and "write" this with the exact formatting I have used (tabs not spaces!)
function test() {
	if(test)
		test != test;
	else {
		test = test;
    }
}


Actual results:

function test() {
if(test)
test != test;
else {
test = test;
}
}


Expected results:

function test() {
	if(test)
		test != test;
	else {
		test = test;
	}
}
<- undefined

The tab key seems to produce "No results" or something for a flash of a second before doing nothing more instead of a tab spacing. In some cases it starts navigating through the developer tools.

Not sure if this is really a bug but I really like how Chrome understands when I want to use tabs instead of spaces like how you're able to use shift + enter/return for a new line in both Chrome & Firefox developer tools.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180410220129

Hello,

I have managed to reproduce this issue on latest Firefox release 59.0.2, latest Nightly build 60.0a1 using Windows 10x64, Mac 10.11.6 and Arch Linux 4.12.

I have written a line in the Browser Console, entered a new row and when I pressed the "Tab" key, the "no result!" text rapidly flashed and no space was inserted.

This issue doesn't seem to be a regression since I've managed to reproduce it on an older Nightly version 50.0a1 (Build ID: 20160606131341).

I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Console
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → x86_64
Product: Firefox → DevTools
Let's try to fix this as part of the jsterm improvements
Blocks: 1458831
Priority: -- → P2
Whiteboard: [boogaloo-mvp]
We'll be handling this in Bug 1472161
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1472161
Priority: P2 → --
Whiteboard: [boogaloo-mvp]
You need to log in before you can comment on or make changes to this bug.