Status

()

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: mkaply, Assigned: mkaply)

Tracking

Trunk
Firefox 61
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox60+ fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
After discussion, Felipe and I have some final tweaks to some policy names/parameters/comments.

This will be the last "official" policy patch to be uplifted. Hurrah!


Rename BlockSetDesktopBackground to DisableSetDesktopBackground

Update ImportEnterpriseRoots comment to say windows only

Rename AcceptThirdParty enums

CreateMasterPassword -> DisableMasterPasswordCreation

DisableSafeMode - document other platform restriction

DisableSysAddonUpdate -> DisableSystemAddonUpdate

DisableTElemetry -> remove access to about:telemetry

Fix InstallAddons description

InstallAddons->InstallAddonsPermission

RememberPassword -> OfferToSaveLogins
Assignee

Updated

Last year
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)

Comment 2

Last year
mozreview-review
Comment on attachment 8965791 [details]
Bug 1452104 - Final tweaks to policy names and params.

https://reviewboard.mozilla.org/r/234624/#review240296

The test for the DisableSysAddonUpdate policy is in another folder:
toolkit/mozapps/extensions/test/xpcshell/test_system_update_enterprisepolicy.js

which will need to be updated too.

With this updated, and assuming that a full folder test passes (`mach test browser/components/enterprisepolicies`), r+
Attachment #8965791 - Flags: review?(felipc) → review+

Comment 3

Last year
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/13d1bdd6e8ce
Final tweaks to policy names and params. r=Felipe

Comment 5

Last year
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/688370d3982d
Backed out changeset 13d1bdd6e8ce per developer's request on IRC on a CLOSED TREE
Comment hidden (mozreview-request)
Assignee

Comment 7

Last year
Backed out because I forgot to push the second change to review. Relanding.
Flags: needinfo?(mozilla)

Comment 8

Last year
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/a3860d8fb4a2
Final tweaks to policy names and params. r=Felipe
Assignee

Comment 9

Last year
Comment on attachment 8965791 [details]
Bug 1452104 - Final tweaks to policy names and params.

Approval Request Comment
[Feature/Bug causing the regression]: Enterprise policy
[User impact if declined]:
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Policy only, minor changes, has tests.
[String changes made/needed]:

This is the final official patch for Enterprise policies

Felipe and I went through and cleared up any strangeness about naming.

We'd like this in for beta 11 so we can call it the official "Full enterprise policy" beta.
Attachment #8965791 - Flags: approval-mozilla-beta?
[Tracking Requested - why for this release]:
Enterprise policies - Final tweaks for the policies names
https://hg.mozilla.org/mozilla-central/rev/a3860d8fb4a2
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8965791 [details]
Bug 1452104 - Final tweaks to policy names and params.

Needed for the policy engine work. Approved for 60.0b11.
Attachment #8965791 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.