Closed Bug 1452471 Opened 2 years ago Closed 2 years ago

Tons of debug build spew (Fix the caller!) while loading XBL doc.

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: emilio, Unassigned)

References

Details

Attachments

(1 file)

Attached file Stack
See the stack. This is firing a lot of times during startup since not long ago, and seemed worth filing.
Are there steps to reproduce this?  I'm not familiar with XBL documents.
Flags: needinfo?(emilio)
Just `./mach run` on my local Linux build spews about ten of these shortly after opening the window.

This is my exact revision: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f981649fdbe7408f070cc6b2e65e1d6d68069024

The patches on top of central are layout patches that shouldn't be related at all afaict, but will try tomorrow morning with a clobber central build.

Mozconfig is:

mk_add_options AUTOCLOBBER=1

CC="/usr/libexec/icecc/bin/clang"
CXX="/usr/libexec/icecc/bin/clang++"

ac_add_options --disable-optimize
ac_add_options --enable-debug

And profile is clean (just ran `rm -rf obj-x86_64-pc-linux-gnu/tmp/scratch_user/` to double-check, and still happens).

XBL documents are loaded from layout synchronously, so I guess I'm surprised this warning wasn't firing up before a couple days ago.

Maybe some frontend patch added DOMContentLoaded listeners to XBL or something, and the lack of those was wallpapering this? IDK.
Flags: needinfo?(emilio)
Ok, it also happens in a central build downloaded from taskcluster.
Boris, not sure this is a regression from that bug, or the warning just started showing up because we take a different code path.

Feel free to just WONTFIX this, or maybe we can whitelist XBL docs from that warning, since we know they run at uncomfortable times...
Flags: needinfo?(bzbarsky)
This is a regression from that bug; I know what's going on.  I will fix it once I actually have a work day.  Please just stop worrying about it and spending time on it.  ;)
Flags: needinfo?(bzbarsky)
Flags: needinfo?(bzbarsky)
See bug 1451966 comment 8 for analysis.  The situation here is similar: we are under a scriptblocker, we're firing an event (DOMContentLoaded) inside a document that is not accessible to script, so this used to be considered OK and now we're warning about it.  The fix for bug 1451966 will fix this.
Depends on: 1451966
Flags: needinfo?(bzbarsky)
Fixed by patch in bug 1451966.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.