Status

enhancement
RESOLVED DUPLICATE of bug 1246706
a year ago
10 months ago

People

(Reporter: lolipopplus, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [design-decision-denied][tabs])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; U; FreeBSD i386 6.98; rv:6.51) (KHTML, like Gecko)  Safari/65.56 Chrome/6.51;
Build ID: 20180404171943

Steps to reproduce:

move your mouse onto any tab


Actual results:

WebExtension is not firing any event


Expected results:

An event should be fired with returning tab info

Updated

a year ago
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Component: WebExtensions: Untriaged → WebExtensions: Frontend
Summary: browser.tabs() needs an Event fired on mouse hover in WebExtension → Add tab hover event to tabs API
Whiteboard: [design-decision-needed][unlikely]
(Reporter)

Updated

a year ago
Blocks: 1226546
(Reporter)

Comment 1

a year ago
because that there is a feature in tab mix plus:
select the tab on mouse hover after X ms

Comment 2

a year ago
A "select tab on mouse hover for n amazon of time" feature would be very useful, especially for accessibility.

Comment 3

a year ago
amount of time
(Reporter)

Updated

a year ago
Flags: a11y-review+
(Reporter)

Comment 4

a year ago
then I would like to set up this flag as comment 2

Updated

a year ago
Flags: a11y-review+
Severity: normal → enhancement
Whiteboard: [design-decision-needed][unlikely] → [design-decision-needed][tabs]
Hi lolipopplus, this has been added to the agenda for the WebExtensions APIs triage on May 8. Would you be able to join us? 

Here’s a quick overview of what to expect at the triage: 

* We normally spend 5 minutes per bug
* The more information in the bug, the better
* The goal of the triage is to give a general thumbs up or thumbs down on a proposal; we won't be going deep into implementation details

Relevant Links: 

* Wiki for the meeting: https://wiki.mozilla.org/WebExtensions/Triage#Next_Meeting
* Meeting agenda: https://docs.google.com/document/d/1TRkZ2u3GQXwlHpfP4-P_SXcwIwvlQz5Sm-C8I89Ya_o/edit#
* Vision doc for WebExtensions: https://wiki.mozilla.org/WebExtensions/Vision
Another nice use case is tab previews on hover.
(Reporter)

Comment 7

a year ago
(In reply to Caitlin Neiman [:caitmuenster] from comment #5)
> Hi lolipopplus, this has been added to the agenda for the WebExtensions APIs
> triage on May 8. Would you be able to join us? 
> 

I check the time, that was 4AM at my local time (GMT+8), so very unlikely.

But I'm pretty sure I will be here whenever you guys flags me up
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246706
This concept was denied in the design-decision meeting; Luca to follow up with a summary of how we arrived at that decision.
Flags: needinfo?(lgreco)
Whiteboard: [design-decision-needed][tabs] → [design-decision-denied][tabs]

Comment 10

11 months ago
This API request has been discussed during the last design-decision meeting and we agreed to deny it, as for the similar Bug 1246706 (which this bug is now marked as a duplicate of).

In Bug 1246706 we have already denied the generic concept of adding arbitrary listeners to mouse API events related to the tab browser UI, and between all the mouse events discussed in that bug (e.g. click / double-click etc.), the mouse hover is definitely the more "transient one", and it is even more likely to potentially be subject to "race conditions" (and related unexpected behaviors) and performance issues (e.g. an extension, even not maliciously, may introduce performance issues by running a heavy task on an event that is potentially fired very often and potentially too late to do anything useful with the work done by that heavy task).
Flags: needinfo?(lgreco)

Comment 11

11 months ago
Please stop being so arrogant.
You removed almost ALL extension functionality in the first place. And know you refuse to add back one simple event listener?

You're basically making it impossible to create an extension for proper mouse gestures, and you've also been discussing to add those natively for 15000 years. Makers of these extensions are being put their back against the wall. On the one hand, users are angry that their mouse gesture extensions are so ****, because someone decided to remove nearly everything that pertains to extensibility and replace it with the atrocious WebExtensions. And on the other hand the same developers have absolutely no way to make their mouse gesture extensions any better, because of the same reason.

This is what we call a "dick move", Mozilla.
(Reporter)

Comment 12

11 months ago
(In reply to Luca Greco [:rpl] from comment #10)
> This API request has been discussed during the last design-decision meeting
> and we agreed to deny it, as for the similar Bug 1246706 (which this bug is
> now marked as a duplicate of).
> 
> In Bug 1246706 we have already denied the generic concept of adding
> arbitrary listeners to mouse API events related to the tab browser UI, and
> between all the mouse events discussed in that bug (e.g. click /
> double-click etc.), the mouse hover is definitely the more "transient one",
> and it is even more likely to potentially be subject to "race conditions"
> (and related unexpected behaviors) and performance issues (e.g. an
> extension, even not maliciously, may introduce performance issues by running
> a heavy task on an event that is potentially fired very often and
> potentially too late to do anything useful with the work done by that heavy
> task).

So, is this indicating that parts of Tab Mix Plus won't be supported anymore?

Comment 13

11 months ago
"Please stop being so arrogant."

Martjin, Bugzilla is our professional working environment as much as it is our issue tracker, and comments like this are not an acceptable use of it. If you intend to continue participating in Bugzilla, I encourage you to review our etiquette and contributor guidelines and take their advice to heart.

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Thank you.
Comment hidden (advocacy)
Comment hidden (abuse-reviewed)
Hi all, conversations in this bug have stopped being productive and have turned into an argument. I am closing comments on this bug.
Restrict Comments: true

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.