taskgraph: Make ship-it tasks support esr60

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: jlorenzo, Assigned: jlorenzo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

Generating a taskgraph with esr60 configs[1] leads to some discrepancies. The things I've noticed are:

* release-mark-as-shipped-firefox
  * Bad version name. This might be caused by bug 1453261 comment 1
  * bad worker type
  * bad scope "project:releng:shipit:staging"

There are probably other issues I didn't see.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1434889#c4
NI'ing myself to fix this, as I worked on the original task def.
Flags: needinfo?(jlorenzo)
(In reply to Johan Lorenzo [:jlorenzo] from comment #0)
> * release-mark-as-shipped-firefox
>   * Bad version name. This might be caused by bug 1453261 comment 1

With the correct data discussed in bug 1453261 comment 4, the release_name in the payload is now correct: "Firefox-60.0esr-build1"
Assignee: nobody → jlorenzo
Flags: needinfo?(jlorenzo)
Comment on attachment 8968183 [details]
Bug 1453266 - Fix bad worker-type and scopes

https://reviewboard.mozilla.org/r/236856/#review242642
Attachment #8968183 - Flags: review?(rail) → review+
Pushed by Callek@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4cc04fbbd1d7
Fix bad worker-type and scopes r=rail
https://hg.mozilla.org/mozilla-central/rev/4cc04fbbd1d7
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.