Feature Request: Uninstall add-on from the Toolbar

RESOLVED DUPLICATE of bug 1401610

Status

()

defect
RESOLVED DUPLICATE of bug 1401610
Last year
Last year

People

(Reporter: fwollsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

Last year
This bug is a suggestion to make it possible to uninstall the add-on directly from the Toolbar. 

Claim: Less users would leave add-ons installed unintentionally with this change.

[Steps to reproduce]:
1. Install any add-on with a browser action
2. Realize that you would like to remove the add-on
3. Right-click on the add-on's browser action

[Expected result]:
- The context menu should include an option to uninstall - "Remove from Firefox"
- Clicking on it should uninstall the add-on

[Actual result]:
- The context menu only includes an option to remove the icon from the Toolbar - "Remove from Toolbar"
- Clicking on it will only remove the add-on icon from the Toolbar but keeps the add-on installed. To actually install it, the following needs to be performed:

1. Click the menu button and choose Add-ons. The Add-ons Manager tab will open.
2. In the Add-ons Manager tab, select the Extensions or Themes panel.
3. Select the add-on you wish to remove.
4. Click the Remove button.
Source: https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons#w_how-to-remove-extensions-and-themes

Updated

Last year
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1401610
You need to log in before you can comment on or make changes to this bug.