Session Restore doesn't activate service worker

RESOLVED DUPLICATE of bug 1437080

Status

()

defect
RESOLVED DUPLICATE of bug 1437080
a year ago
a year ago

People

(Reporter: xfalcox, Unassigned)

Tracking

59 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:

1. Open a Discourse site, like: https://discourse.mozilla.org

2. Close Firefox

3. Open Firefox

4. Click on "Restore Previous Session" (or have it enabled by default)


Actual results:

Offline page shows up.

The service worker fetch returns the cached offline page.

Screenshot: https://screenshots.firefox.com/yzo5jTDHkt2HKajQ/discourse.mozilla.org


Expected results:

Site should appear, either from cache or reloading the page on session restore.
Reporter

Updated

a year ago
OS: Unspecified → All
Hardware: Unspecified → All
Component: Untriaged → DOM: Service Workers
Product: Firefox → Core
Flags: needinfo?(bkelly)
This appears to be fixed in FF60 which ships May 9.  I'm 95% sure this was corrected by bug 1437080.  Session restore effectively sets "force-cache" on the network request for the document.  FF59 and earlier have a bug which mistranslate this to "only-if-cached" when created FetchEvent.request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bkelly)
Resolution: --- → DUPLICATE
Duplicate of bug: 1437080
Reporter

Comment 2

a year ago
Thanks heaps @bkelly !
You need to log in before you can comment on or make changes to this bug.