Updating Lightning in TB 60.0 beta breaks it

RESOLVED DUPLICATE of bug 1452120

Status

defect
--
major
RESOLVED DUPLICATE of bug 1452120
Last year
Last year

People

(Reporter: walts48, Unassigned)

Tracking

Lightning 6.2

Details

Attachments

(1 attachment)

Posted image error_console.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180416100103

Steps to reproduce:

Installed Thunderbird 60.0b1
Started Thunderbird with a new profile, clicked Keep to keep Lightning
Noted that it has Lightning 6.2b1 installed and working properly
Updated TB 60.0b1 to 60.0b2 and restarted to apply updates
Noted that Lightning 6.2b1 is still the installed version, working properly
Did a Check for Updates. There are no updates found for Lightning
Downloaded and installed Lightning 6.2b2 over 6.2b1 using "Install Add-on From File"


Actual results:

Restarted and Lightning 6.2b2 doesn't work, the Calendar tab won't open, and "Today Pane" appears in the Status Bar, but there is no content

Also happens if you update 6.2b2 to 6.2b3 in TB 60.0b2


Expected results:

Lightning update should have applied and the extension work as expected.
Severity: normal → major
Yes, as far as I know using Lightning from xpi file is no longer working. See Bug 1452120 Comment 5 for workaround to get working Lightning. Bug 1406499 should be the fix?
I'll close this bug, since this is a duplicate of bug 1452120, which is marked as a duplicate of bug 905097.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1452120
You need to log in before you can comment on or make changes to this bug.