Closed Bug 1454631 Opened 2 years ago Closed 2 years ago

Remove nsIXULBrowserWindow::forceInitialBrowserRemote

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: dao, Assigned: dao)

Details

Attachments

(1 file)

forceInitialBrowserRemote is only called from pageloader.js which doens't need an XPCOM interface for this.

(Also not sure if nsWindowWatcher still needs to call forceInitialBrowserNonRemote; this code could use some documentation.)
Comment on attachment 8968524 [details]
Bug 1454631 - Remove nsIXULBrowserWindow::forceInitialBrowserRemote.

https://reviewboard.mozilla.org/r/237212/#review243710

Yeah, looks like we force the initial browser to be remote early enough in its lifetime that this isn't necessary anymore (it used to be needed by TabParent when content was opening new windows).

I can confirm that it's no longer needed for opening windows from content.

Thanks for removing it!
Attachment #8968524 - Flags: review?(mconley) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7996758e0e8
Remove nsIXULBrowserWindow::forceInitialBrowserRemote. r=mconley
https://hg.mozilla.org/mozilla-central/rev/a7996758e0e8
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.