Closed Bug 1454653 Opened Last year Closed Last year

Layer isn't transparent on web.whatsapp.com

Categories

(Core :: Web Painting, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 + verified

People

(Reporter: jnicol, Assigned: miko)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

Attached image whatsapp opacity.png
I've noticed an opacity issue on web.whatsapp.com

Attached is a screenshot. The layer with the messages on it should be transparent, and the background pattern you can see to the side of it should be shown behind it.

Resizing the window causes the layer in question to switch between having a cyan diagnostic border, ie component alpha, where the background is displayed correctly. And having a green diagnostic border, ie no component alpha, where the background is blocked, as in the screenshot.

Suspected it was due to recent opacity flattening work, and indeed the regression range confirms that:

20:26.97 INFO: Narrowed inbound regression window from [0f807bee, 9866b049] (3 > builds) to [0f807bee, 665843c6] (2 builds) (~1 steps left)
20:26.97 INFO: No more inbound revisions, bisection finished.
20:26.97 INFO: Last good revision: 0f807beef229718c015553bac09e4f638ca2add1
20:26.97 INFO: First bad revision: 665843c6cfd1a3049128597afbef8a68bcc1e086
20:26.97 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0f807beef229718c015553bac09e4f638ca2add1&tochange=665843c6cfd1a3049128597afbef8a68bcc1e086
Assignee: nobody → mikokm
Priority: -- → P2
Status: NEW → ASSIGNED
Comment on attachment 8970225 [details]
Bug 1454653 - Do not skip transparent items in ContainerState::FindOpaqueBackgroundColorInLayer()

https://reviewboard.mozilla.org/r/239022/#review244800
Attachment #8970225 - Flags: review?(matt.woodrow) → review+
Pushed by mikokm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ce1d9b338bda
Do not skip transparent items in ContainerState::FindOpaqueBackgroundColorInLayer() r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/ce1d9b338bda
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Blocks: 1455908
Hello, I tried reproducing the issue on an older version of firefox 61.0a1 (2018-04-10) without any success, i retested the issue on the latest version 61.0a1 (2018-04-29) - Windows 10 and it doesn't reproduce there either.

I can Confirm it as fixed and i will mark it as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
I did however manage to reproduce the Issue on build 61.0a1 (2018-04-12) on Windows 10.
You need to log in before you can comment on or make changes to this bug.