Closed Bug 1454962 Opened 2 years ago Closed 1 year ago

Developer tools network columns sorting can't be reset

Categories

(DevTools :: Netmonitor, defect, P3)

59 Branch
defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: _+bugzilla, Assigned: mrigankkrishan)

References

Details

(Keywords: dev-doc-needed)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180323154952

Steps to reproduce:

* Open F12 developer tools
* Switch to the network tab
* Click on a column header to sort the table


Actual results:

It remains sorted forever, I can only change the sorting but not undo it


Expected results:

I should be able to reset the sorting to its initial state, for example by clicking three times or some menu command
Component: Untriaged → Developer Tools: Netmonitor
Thanks for the report!

@Harald, we could:

1) use the existing "Reset Columns" action in Header context menu to reset the sorting
2) introduce new "Reset Sorting" action in Header context menu
3) use third click on the same header to reset the sorting for that column
4) or do anything else?

What do you think?

Honza
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(hkirschner)
Priority: -- → P3
"Reset state" means sorted by Timeline, correct?

> 2) introduce new "Reset Sorting" action in Header context menu
> 3) use third click on the same header to reset the sorting for that column

I would go for both as they make the reset discoverable in different ways.
Flags: needinfo?(hkirschner)
Product: Firefox → DevTools

Hi,
I would like to work on this. I'm working on a patch for this right now.

Flags: needinfo?(odvarko)

As suggested by @Harald, I've added two ways to "Reset state":

  • Middle click on request list header.
  • "Reset Columns" option in the context menu will also sort by timeline.

Thanks for the update!

Comments made in phabricator.

Honza

Flags: needinfo?(odvarko)
Attachment #9048425 - Attachment description: feat: sort columns → Bug 1454962 - Add ways to reset sorting. r=Honza

If this issue is still open, can I try solving it ?

Attachment #9050057 - Attachment is obsolete: true

(In reply to Pranshu Chittora from comment #6)

If this issue is still open, can I try solving it ?

Sorry, Mrigank is already working on this.

Honza

Assignee: nobody → mrigankkrishan
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Duplicate of this bug: 1569764
You need to log in before you can comment on or make changes to this bug.