Closed Bug 145507 Opened 18 years ago Closed 18 years ago

DTD entities appear to break XSL parsing

Categories

(Core :: XSLT, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 22942

People

(Reporter: gnubeutel, Assigned: peterv)

Details

1.0 rc2

When i define an entity in a DTD and try to use XSL to reformat the XML to HTML,
and the XML uses the defined entity, i get no output at all. Not even an error
message.
(When i use IE, i get what i want.)

When i remove the entity from the XML, the resulting HTML looks correct (but
does not have the entity, of course).

e.g
DTD:
  <!ELEMENT foo (#PCDATA)>
  <!ENTITY copy   "&#169;" >

XML:
  <foo>
    &copy; 1999
  </foo>

XSL (contains):
  <xsl:template match="foo">
    <xsl:copy-of select="*|@*|text()"/>
  </xsl:template>
To XSLT
Assignee: heikki → peterv
Component: XML → XSLT
QA Contact: petersen → keith
mozilla doesn't support external entities. If you move the entity-definition 
into the xml-file it should work just fine.

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.