Firefox lists external apps even if the network.protocol-handler.external-default is false

RESOLVED FIXED in Firefox 61

Status

()

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: igt0, Assigned: igt0)

Tracking

Trunk
Firefox 61
Points:
---

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180326160923

Steps to reproduce:

1. go to about:config and set   network.protocol-handler.external-default to false
2. go to ​http://mcomella.xyz/test/uri.html
3. Install zxing application
4. click and hold in any link in the page


Actual results:

Context menu allows the user to open an external app


Expected results:

External apps should not be shown in the context menu.
Flags: needinfo?(mark.finkle)
Attachment #8969138 - Flags: review?(bugzilla)
Flags: needinfo?(ntim.bugs)
Not sure what's being requested from me here, I don't work on Android.
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(mark.finkle)
Attachment #8969138 - Flags: review?(bugzilla) → review?(michael.l.comella)
Comment on attachment 8969138 [details] [diff] [review]
0001-Bug-1455165-Filter-external-apps-out-if-needed.patch

Review of attachment 8969138 [details] [diff] [review]:
-----------------------------------------------------------------

I tested this locally: this fixes the given STR. I'm not entirely certain what side effects it may have (e.g. where else is ExternalApps used?) but since it's an about:config object, I think it's safe to add.
Attachment #8969138 - Flags: review?(michael.l.comella) → review+
Here's a try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ae4c423e7d9804b6896b2603aca8500a9a8030fc&selectedJob=175438636

When everything is green (excepting the initial gecko decision task - I don't know why it failed), please add the "checkin-needed" keyword to get this checked in.
Flags: needinfo?(igt0)
Flags: needinfo?(igt0)
Keywords: checkin-needed
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a092f00fdd6
Filter external apps out if needed. r=mcomella
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9a092f00fdd6
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.