Pass an `openLink` prop to Reps

VERIFIED FIXED in Firefox 61

Status

defect
VERIFIED FIXED
Last year
Last year

People

(Reporter: nchevobbe, Assigned: yzen)

Tracking

(Blocks 1 bug)

Trunk
Firefox 62
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox61 verified, firefox62 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The panel uses Reps, which automatically "linkify" links in strings.
But in order to be handled, we need to pass an `openLink` prop to Rep so it can actually open the link in a new tab (see https://searchfox.org/mozilla-central/source/devtools/client/webconsole/utils/object-inspector.js#67)
Reporter

Updated

Last year
Blocks: 1151468
Assignee

Comment 1

Last year
Posted patch 1455276 patch (obsolete) — Splinter Review
Attachment #8981473 - Flags: review?(nchevobbe)
Assignee

Updated

Last year
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Comment on attachment 8981473 [details] [diff] [review]
1455276 patch

Review of attachment 8981473 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me, thanks yura.
It would be nice to have a test to make sure it works as intended.
Also, we could handle Ctrl/Cmd + click to open tab in the background (see https://searchfox.org/mozilla-central/rev/5a744713370ec47969595e369fd5125f123e6d24/devtools/client/webconsole/hudservice.js#367-371)
Attachment #8981473 - Flags: review?(nchevobbe) → review+

Comment 3

Last year
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9b53708a3203
ensure links in strings can open in Accessible properties. r=nchevobbe

Comment 4

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/9b53708a3203
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Assignee

Comment 5

Last year
Carry over
Attachment #8981473 - Attachment is obsolete: true
Attachment #8982210 - Flags: review+
Assignee

Comment 6

Last year
Comment on attachment 8982210 [details] [diff] [review]
1455276 updated patch

[Feature/Bug causing the regression]: Not a regression, supports a11y inspector deliverable for Fx61
[User impact if declined]: Users won't be able to click links (and navigate to URLS) that are rendered in a11y inspector sidebar.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: Only adds ability to click on links in a11y inspector sidebar by using existing functionality in Reps.js. Also covered by tests.
[String changes made/needed]: None
Attachment #8982210 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 8982210 [details] [diff] [review]
1455276 updated patch

a11y inspector improvement. Approved for 61.0b11.
Attachment #8982210 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This issue is verified fixed using Firefox 62.0a1 (BuildId:20180604100129) and Firefox 61.0b11 (BuildId:20180604143143) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.