Closed Bug 1455636 Opened 3 years ago Closed 3 years ago

limited usability of browserSettings.proxyConfig.set

Categories

(Firefox :: Untriaged, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1455705

People

(Reporter: richard.neomy, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.117 Safari/537.36

Steps to reproduce:

The current implementation of `browserSettings.proxyConfig.set` does not allow setting an IP address without a schema. This is problematic in many cases. See https://github.com/rNeomy/proxy-switcher/issues/46 for examples.


Actual results:

var proxySettings = {
  proxyType: "manual",
  http: "127.0.0.1:8080",
  socksVersion: 5
};

browser.browserSettings.proxyConfig.set({value: proxySettings});

returns "Error: 127.0.0.1:8080 is not a valid value for http"


Expected results:

127.0.0.1 is set for the "network.proxy.http" pref and 8080 is set for "network.proxy.http_port" pref
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(bob.silverberg)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(bob.silverberg)
Resolution: --- → DUPLICATE
Duplicate of bug: 1455705
You need to log in before you can comment on or make changes to this bug.