Closed Bug 1456441 Opened 2 years ago Closed 1 year ago

Intermittent devtools/client/debugger/new/test/mochitest/browser_dbg-pause-exceptions.js | Expected pause line on line 2, it is on 2 -

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 62

People

(Reporter: intermittent-bug-filer, Assigned: CosminS)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disabled])

Attachments

(1 file, 2 obsolete files)

Started doing retriggers for this failure: 
 'devtools/client/debugger/new/test/mochitest/browser_dbg-pause-exceptions.js | Expected pause line on line 2, it is on 2'

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=opt-mochitest-devtools-chrome-e10s&tochange=5579f92920c321f2011db2dbe4118bb3110a46fc&fromchange=9938026038b1d8e5884a61b8ab77ee9aff478ae1&selectedJob=175265149

on the following pushes: 
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=opt-mochitest-devtools-chrome-e10s&tochange=5579f92920c321f2011db2dbe4118bb3110a46fc&fromchange=9938026038b1d8e5884a61b8ab77ee9aff478ae1

and I believe the failure originated from this push: 
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=3ad2e050c66a73c748761d451d2c7a5339501773&filter-searchStr=opt-mochitest-devtools-chrome-e10s

as there are no similar failures on the retriggered jobs.

:jmaher could you please have a look, when you got the time?
Flags: needinfo?(jmaher)
Whiteboard: [retriggered]
thanks for doing this Tiberius.  There are a lot of other failures in dt4 which makes this hard to see the failure pattern.  I did some retriggers (30+ on a few revisions) to see if this yields more failures:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=dt4%20win%20pgo&tochange=3ad2e050c66a73c748761d451d2c7a5339501773&fromchange=6bb7337970f19723f9ba34a682b4682c53863e5a

With only 1 or 2 failures in 30 retriggers, it is hard to see a clear pattern.  I would say when those results come back if we do not have at least 4 failures it then becomes difficult to show a clear failure rate.
Flags: needinfo?(jmaher)
After the retriggers were done we noticed that from those three pushes, only the first and second had a single failure on that particular file, the third one had failures but none of them were on the file that we were interested.
Is there a next step in this case?
Flags: needinfo?(jmaher)
Thanks for working on this Noemi- I am confused why we get so many failures on the trees, yet cannot reproduce this.  I think finding a root cause with retriggers is not straightforward in this case.
Flags: needinfo?(jmaher)
Attached patch Disable on Win 7 pgo (obsolete) — Splinter Review
Made a patch for this test to be disabled on Win 7 pgo due to the high failure rate. Please review. Thanks.
Attachment #8973615 - Flags: review?(nbeleuzu)
Attachment #8973615 - Flags: review?(cbrindusan)
Attachment #8973615 - Flags: review?(cbrindusan) → review+
Attached patch Disable on Win 7 pgo (obsolete) — Splinter Review
Updated the patch with the os version for windows 7.
Attachment #8973615 - Attachment is obsolete: true
Attachment #8973615 - Flags: review?(nbeleuzu)
Attachment #8973617 - Flags: review?(nbeleuzu)
Attachment #8973617 - Flags: review?(cbrindusan)
Comment on attachment 8973615 [details] [diff] [review]
Disable on Win 7 pgo

Review of attachment 8973615 [details] [diff] [review]:
-----------------------------------------------------------------

I would add os_version == "6.1"
skip-if = os = !debug && ("win" && os_version == "6.1") # Bug 1456441
Attachment #8973615 - Attachment is obsolete: false
Attachment #8973615 - Flags: review-
Corrected the syntax.
Attachment #8973618 - Flags: review?(nbeleuzu)
Attachment #8973618 - Flags: review?(cbrindusan)
Sorry, wanted to say: skip-if = !debug && (os == "win" && os_version == "6.1")
Attachment #8973617 - Attachment is obsolete: true
Attachment #8973617 - Flags: review?(nbeleuzu)
Attachment #8973617 - Flags: review?(cbrindusan)
Attachment #8973615 - Attachment is obsolete: true
Attachment #8973618 - Flags: review?(nbeleuzu) → review+
Attachment #8973618 - Flags: review?(cbrindusan) → review+
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efd94fbb9f42
Disable devtools/client/debugger/new/test/mochitest/browser_dbg-pause-exceptions.js on Win 7 pgo. r=nbeleuzu,cbrindusan
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell disabled]
https://hg.mozilla.org/mozilla-central/rev/efd94fbb9f42
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Target Milestone: Firefox 61 → Firefox 62
Assignee: nobody → csabou
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Assignee: csabou → nobody
This is not fixed, I just made a patch to disable the test because of the high failure rate. It was disabled only on win 7 pgo.
Thanks i believe we have a fix for 62 nightly. It was difficult to hunt down, but i believe was effecting other tests a bit as well.
Flags: needinfo?(jlaster)
Product: Firefox → DevTools
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.