Closed Bug 1456504 Opened 3 years ago Closed 3 years ago

"grid-template-columns: repeat(auto-fit, minmax(150px, 1fr) minmax(150px, 1fr))" is rejected in Firefox

Categories

(Core :: CSS Parsing and Computation, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1341507

People

(Reporter: dholbert, Unassigned)

Details

STR:
 1. Load http://jsbin.com/pojepohuwe/edit?html,css,output
 2. Look at rendering and compare to other browsers.

ACTUAL RESULTS:
3 columns of numbers in Chrome; 2-3 in Edge, space-permitting.
1 column in Firefox.


Not sure who's right. It looks like we're rejecting the grid-template-columns syntax, though, since it's crossed out in devtools:
grid-template-columns: repeat(auto-fit, minmax(150px, 1fr) minmax(150px, 1fr));

Mats, do you know what might be going on?  I do see this in the spec:
> Automatic repetitions (auto-fill or auto-fit)
> cannot be combined with intrinsic or flexible sizes.

...so maybe we're rejecting due to that rule and the "1fr" usage here? Not sure. Maybe chrome needs a bug filed, if that's the case?
(This was reported via Twitter BTW: https://twitter.com/FirefoxDevTools/status/988680927806214144 )
Flags: needinfo?(mats)
Flags: needinfo?(mats)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341507
Bug 1341507 might be a good project for an intern BTW.
You need to log in before you can comment on or make changes to this bug.