[CSD] Background tabs are unreadable in fullscreen windows on Ubuntu

VERIFIED FIXED in Firefox -esr60

Status

()

defect
P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Blocks 1 bug, {regression})

Trunk
Firefox 61
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 verified, firefox59 unaffected, firefox60 verified, firefox61 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
I believe bug 1439834 broke this.
(Assignee)

Updated

a year ago
Summary: Background tabs are unreadable in fullscreen windows on Ubuntu → [CSD] Background tabs are unreadable in fullscreen windows on Ubuntu
(Assignee)

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED

Comment 2

a year ago
mozreview-review
Comment on attachment 8970589 [details]
Bug 1456522 - Stop making the tabs toolbar transparent when there's no title bar behind it, i.e. in fullscreen mode.

https://reviewboard.mozilla.org/r/239346/#review245244

Yes, that makes sense, Thanks!
Attachment #8970589 - Flags: review?(stransky) → review+

Comment 3

a year ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/a2d670a8074e
Stop making the tabs toolbar transparent when there's no title bar behind it, i.e. in fullscreen mode. r=stransky
We may want to request uplift for 60ESR...
(Assignee)

Updated

a year ago
Flags: qe-verify+

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a2d670a8074e
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
(Assignee)

Comment 6

a year ago
Comment on attachment 8970589 [details]
Bug 1456522 - Stop making the tabs toolbar transparent when there's no title bar behind it, i.e. in fullscreen mode.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1439834
[User impact if declined]: on Linux, with the title bar disabled, background tabs are unreadable in fullscreen mode
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: disable the title bar in customize mode and make the browser window fullscreen
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: isolated CSS fix
[String changes made/needed]: /
Attachment #8970589 - Flags: approval-mozilla-beta?
Comment on attachment 8970589 [details]
Bug 1456522 - Stop making the tabs toolbar transparent when there's no title bar behind it, i.e. in fullscreen mode.

Looks like a good low-risk ride-along for the first Fx60 RC build.
Attachment #8970589 - Flags: approval-mozilla-beta? → approval-mozilla-release+
I verified this issue on Ubuntu 16.04 with FF Nightly 61.0a1(2018-04-22) and I was able to reproduce this issue. I tested with the latest Nightly 61.0a1(2018-04-29) and the issue is no longer reproducible. 
We will verify this also in beta after the fix will be uplifted.
This issue was also verified on Ubuntu 16.04 with FF 60.0 candidates and I wasn't able to reproduce it.
I verified this issue on FF 60.0esr build 6 with Ubuntu 16.04 and I can confirm that the issue is fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.