Text with non-standard line height not redrawn properly

VERIFIED DUPLICATE of bug 80530

Status

()

Core
Layout
P3
major
VERIFIED DUPLICATE of bug 80530
16 years ago
16 years ago

People

(Reporter: Christian Schmidt, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Sun
SunOS
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Sometimes when scrolling a page, some text lines are not redrawn properly. It
looks as if one line of pixels is missing.

It seems to happen only within paragraphs with line-height set to something
other than normal.


I am using Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.0+) Gecko/20020514.
This was also the problem in the April 18th build.
(Reporter)

Comment 1

16 years ago
Created attachment 84243 [details]
Test case
(Reporter)

Comment 2

16 years ago
Created attachment 84244 [details]
Screenshot of testcase
(Reporter)

Comment 3

16 years ago
To experience the problems you have to scroll using the arrow keys or the arrows
on the scrollbar (i.e. not PgUp/PgDn or the scrollbar thumb).

If the window is covered by another window and then brought to top again, the
text lines are drawn correctly.


Notice that the problem does not occur when line height is not specified, or
when the specified height is the same as when no height is specified (i.e. 11px
when font size is 10px, and 13px when font size is 11px or 12 px).

The problem occurs on quite a lot of sites, so I'm setting severity to 'major'.
Severity: normal → major
Keywords: testcase
(Reporter)

Comment 4

16 years ago
Hmm, appearently it is not only on text that has line-height specified.

Steps to reproduce:
1. Open http://linuxtoday.com/news_story.php3?ltsn=2002-05-20-006-26-IN-LF-PB
2. Press down arrow key (or hold it pressed) until the subheader "Peruvian Bill
Number 1609, Free Software in Public Administration" scrolls into view.

The whole following subsection is drawn improperly. From the subheader "Writing
the Letter" and to the end of the page everything is right again, i.e. the
problem only occurs between those to subheaders.

Comment 5

16 years ago
Changing QA contact to Moied
QA Contact: petersen → moied

Updated

16 years ago
Priority: -- → P3

Comment 6

16 years ago
This is almost certainly a twips rounding problem.

*** This bug has been marked as a duplicate of 80530 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.