[TreeView] Left arrow on non expandable or collapsed node should select parent node.

VERIFIED FIXED in Firefox 61

Status

defect
--
minor
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: george.craciun, Assigned: yzen)

Tracking

(Blocks 1 bug)

61 Branch
Firefox 62

Firefox Tracking Flags

(firefox61 verified, firefox62 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180424100107

[Affected versions]:
Nightly 61.0a1

[Affected Platforms]:
All

[Prerequisites]:
Accessibility tab is opened and enabled

[Steps to reproduce]: 
1.Click the "document" item from the "Role" panel.
2.Select the first line without a dropdown arrow
3.Press the "Left arrow" key and observe what happens next.

[Expected result]:
-The "document" parent row should be selected 
Please see Comment 1 from bug 1439630

[Actual result]:
-Nothing happens, the "Left arrow" key is not used to navigate through lines.

Note that in the Inspector Tab/Properties panel for example, pressing the "Left arrow" key on a child row without dropdown arrow, moves the selected row back to the parent and pressing again the "Left arrow" key closes the child row.
(Reporter)

Updated

a year ago
Blocks: 1151468
(Reporter)

Comment 1

a year ago
Please note that the issue is also occurring when using the "Right arrow" key.
Summary: Pressing the "Left arrow" key doesn't selects the parent item if a child item was previously selected → Pressing the "Left arrow"/"Right arrow" key doesn't navigate through the child rows of the "Role" panel
(Assignee)

Comment 2

11 months ago
(In reply to Cristian Craciun from comment #1)
> Please note that the issue is also occurring when using the "Right arrow"
> key.

Right arrow navigate to next node is not desired and is confusing to a11y users. We disable it by default in the VirtualizedTree component.
(Assignee)

Updated

11 months ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Summary: Pressing the "Left arrow"/"Right arrow" key doesn't navigate through the child rows of the "Role" panel → Left arrow on non expandable or collapsed node should select parent node.
(Assignee)

Updated

11 months ago
Component: Developer Tools: Accessibility Tools → Developer Tools: Shared Components
Summary: Left arrow on non expandable or collapsed node should select parent node. → [TreeView] Left arrow on non expandable or collapsed node should select parent node.
(Assignee)

Comment 3

11 months ago
Posted patch 1456756 patch (obsolete) — Splinter Review
Attachment #8981233 - Flags: review?(odvarko)
Comment on attachment 8981233 [details] [diff] [review]
1456756 patch

Review of attachment 8981233 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch!

R+, assuming try is green.

Honza
Attachment #8981233 - Flags: review?(odvarko) → review+

Comment 5

11 months ago
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc76999d8ee0
select parent row if available when ArrowLeft is pressed on collapsed or non-expandable row. r=Honza

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fc76999d8ee0
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
(Assignee)

Comment 7

11 months ago
Carry over
Attachment #8981233 - Attachment is obsolete: true
Attachment #8982209 - Flags: review+
(Assignee)

Comment 8

11 months ago
Comment on attachment 8982209 [details] [diff] [review]
1456756 updated patch

[Feature/Bug causing the regression]: Not a regression, supports a11y inspector deliverable for Fx61
[User impact if declined]: Users won't be able to use keyboard to jump to parent accessible object in accessibility tree when pressing ArrowLeft.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Same STR as in description.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: Just improves keyboard navigation, when pressing left arrow within TreeView
[String changes made/needed]: None
Attachment #8982209 - Flags: approval-mozilla-beta?
Comment on attachment 8982209 [details] [diff] [review]
1456756 updated patch

a11y inspector improvement. Approved for 61.0b11.
Attachment #8982209 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

Comment 11

11 months ago
Hi Everyone , i managed to reproduce this issue using the 61.0a1 (2018-05-01) version of Nightly but i can no longer reproduce this issue on the later versions of it.
I will mark this issue accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.