When using multiple tabs, quit should raise a confirmation dialog

VERIFIED DUPLICATE of bug 108973

Status

--
major
VERIFIED DUPLICATE of bug 108973
17 years ago
14 years ago

People

(Reporter: coffeebreaks, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Because tabs are a still rather new feature, some people may make a mistake
chosing 'File->Quit' and closing the whole browser, not thinking that many tabs
are opened and will also be closed.

In the case one choses Quit, a dialog should popup and warn the user that many
tabs are opened.

Dialog suggestion:

------------------------------------------------------
|      Warning - Quitting application ?              |
|                                                    |
|   Several tabs are opened.                         |
|   Quitting will close them all.                    |
|                                                    |
|  _______________                       _________   |
|  | Quit Anyway? |                      | Cancel |  |
|  |______________|                      |________|  |
|                                                    |
|  ( ) Do not show me this dialog in the future.     |
|____________________________________________________|


I put severity as major as there is an obvious risk of data loss. 
I was sure they would be a duplicate but couldn't find it searching for 'quit'
and 'quit tab'.
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 108973 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.