Move Payment Request UI code to browser/

RESOLVED FIXED in Firefox 61

Status

()

enhancement
P1
normal
RESOLVED FIXED
Last year
2 months ago

People

(Reporter: MattN, Assigned: MattN)

Tracking

Trunk
Firefox 61
Points:
---

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: [webpayments])

Attachments

(1 attachment, 1 obsolete attachment)

It seems like mobile won't re-use our UI and we want to depend on stuff in browser/ so we should just move to browser/components/ ourselves.
Comment hidden (mozreview-request)
Comment on attachment 8971447 [details]
Bug 1457287 - Move Payment Request UI code to browser/.

https://reviewboard.mozilla.org/r/240194/#review246006
Attachment #8971447 - Flags: review?(jaws) → review+
Comment hidden (mozreview-request)

Comment 4

Last year
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/a8fef6308479
Move Payment Request UI code to browser/. r=jaws
Comment hidden (mozreview-request)
Comment on attachment 8971451 [details]
Bug 1457287 - Follow-up to fix browser_address_edit.js.

https://reviewboard.mozilla.org/r/240200/#review246014
Attachment #8971451 - Flags: review?(jaws) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 4c03e2488429b240ada210ea83af94eba14c2c47 -d d52b265b6b52: rebasing 460801:4c03e2488429 "Bug 1457287 - Follow-up to fix browser_address_edit.js. r=jaws" (tip)
merging browser/components/payments/content/paymentDialogWrapper.js
warning: conflicts while merging browser/components/payments/content/paymentDialogWrapper.js! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Could not land this patch because of the conflict above.
Flags: needinfo?(MattN+bmo)
Comment hidden (mozreview-request)
Flags: needinfo?(MattN+bmo)
Comment hidden (mozreview-request)

Comment 11

Last year
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ae9810db352
Follow-up to fix browser_address_edit.js. r=jaws on a CLOSED TREE
See Also: → 1457369

Comment 12

Last year
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9424d87854e4
Backed out 2 changesets for browser chrome failures on browser_address_edit.js. CLOSED TREE
Attachment #8971451 - Attachment is obsolete: true

Comment 13

Last year
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51808b0ecdc8
Move Payment Request UI code to browser/. r=jaws
https://hg.mozilla.org/integration/autoland/rev/eac9464a3c3f
Backed out changeset a8fef6308479 for conflicts during backout. CLOSED TREE
Part 1 landed to allow a back out and got backed out after this.

https://hg.mozilla.org/integration/autoland/rev/eac9464a3c3f5ba8ba43e8c9f7e6310883e2bf28
Flags: needinfo?(MattN+bmo)

Comment 15

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/51808b0ecdc8
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61

Comment 16

Last year
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3e459e1186fe
Move Payment Request UI code to browser/. r=jaws
Flags: needinfo?(MattN+bmo)
Product: Toolkit → Firefox
Target Milestone: mozilla61 → Firefox 61

Comment 18

Last year
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/21fa5fd2a00a
Update Bugzilla Product for WebPayments UI. r=me DONTBUILD
Regressions: 1547842
You need to log in before you can comment on or make changes to this bug.