Closed Bug 1457520 Opened 2 years ago Closed 9 months ago

POST requests and POST data don't survive process switches

Categories

(Core :: DOM: Content Processes, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1467223
Tracking Status
firefox61 --- affected

People

(Reporter: adw, Unassigned)

References

(Depends on 1 open bug)

Details

When a POST request starts in one process but is redirected to another, we don't send along its POST data.  See bug 1435615 comment 6.

Mike, please feel free to correct/change this bug.  I filed it in Firefox :: Tabbed Browser since that's where bug 1376895 is filed, but I'm not sure whether that's the best place.

(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from bug 1435615 comment #11)
> Can you please file a new bug to correct this, and mark is as depending on
> bug 1344465? And then perhaps reference that new bug here? We should
> probably get this all fixed up once bug 1344465 gets fixed.
See Also: → 1347983, 1348018, 1344465
See Also: → 1435615
Component: Tabbed Browser → DOM: Content Processes
Product: Firefox → Core
Priority: -- → P3
This looks like a Fission blocker, but I think the browsing context redesign would take care of this?
Blocks: fission
InputStream can be sent via StructuredCloneHolder and they should work cross-processes. We send them from child to parent or parent to child for Blobs, of instance.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1467223
No longer blocks: fission
You need to log in before you can comment on or make changes to this bug.