Closed Bug 1458061 Opened Last year Closed Last year

Implement ability to reload a selection of tabs

Categories

(Firefox :: Tabbed Browser, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed
firefox64 --- verified
firefox65 --- verified

People

(Reporter: ablayelyfondou, Assigned: ablayelyfondou, Mentored)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

When a group of tabs are selected, right-clicking on any tab in the selection should:
 1. Provide a context menu option of "Reload selected tabs".
 1. The "Reload tab" option will be hidden.
Sorry the second option listed above should be numbered 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does this feature affect to the WebExtensions API: browser.tabs.reload(id)? When one of multiselected tab is updated, all multiselected tabs should be reloaded also?
(In reply to YUKI "Piro" Hiroshi from comment #2)
> Does this feature affect to the WebExtensions API: browser.tabs.reload(id)?
> When one of multiselected tab is updated, all multiselected tabs should be
> reloaded also?

I don't think we want that, instead I would suggest the following:
browser.tabs.query({currentWindow: true, highlighted: true}).then((tabs) => {
  for(tab of tabs){
    browser.tabs.reload(tab.id);
  }
}, null);
Yes, I agree with Geoffrey.
Assignee: nobody → ablayelyfondou
Mozreview has gotten confused here and I can't submit a review (I get an http 500 error). :-(

Here are my review comments anyway:

Overall: Somehow mozreview has gotten confused here and there's no summary listed, and it's been put on bugzilla twice. Both bugzilla reviews point to the same mozreview changeset so I assume one review is enough. I hope landing it works, otherwise let me know and I can land it on inbound.

Anyway, this looks good with these minor points below addressed. Thank you!


Top of the new test file:
Nit: please include a public domain license header on the test file.


About the access key in the .dtd:
Given *either* Reload Tab *or* Reload Selected Tabs is visible, I assume you can use the same access key here (ie "R").

Also, just like with `Unpin Tab and Unpin Selected Tabs`, it's probably worth adding a localization comment so that localizers are aware of this.
Comment on attachment 8989093 [details]
Bug 1458061 - Implement ability to reload a selection of tabs.

r=me with the comments in my previous comment on the bug, though mozreview seems to be in a bad state wrt this commit. You may want to use `hg export` and attach the cset with the comments addressed on the bug, then set checkin-needed and obsolete the mozreview attachments.
Attachment #8989093 - Flags: review?(gijskruitbosch+bugs) → review+
Attachment #8989094 - Flags: review?(gijskruitbosch+bugs)
(In reply to :Gijs (he/him) from comment #7) 
> Top of the new test file:
> Nit: please include a public domain license header on the test file.

Yes, I did with the first patch submitted and this is what I got from Jared (comment https://bugzilla.mozilla.org/show_bug.cgi?id=1458010#c8): 

"Test code is normally licensed under Public Domain. You can remove the license header here, and by default the test will fall under Public Domain based on the Licensing of Mozilla Code section of https://www.mozilla.org/en-US/MPL/license-policy/".

Since then I don't add licence header on test files. What do you think?
MozReview-Commit-ID: CyJLk7pxGRr
Attachment #8989229 - Flags: checkin?(gijskruitbosch+bugs)
Attachment #8989094 - Attachment is obsolete: true
Attachment #8989093 - Attachment is obsolete: true
Attachment #8989093 - Flags: review?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1050ddd2bad8
Implement ability to reload a selection of tabs. r=Gijs
Attachment #8989229 - Flags: checkin?(gijskruitbosch+bugs) → checkin+
https://hg.mozilla.org/mozilla-central/rev/1050ddd2bad8
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Verified fixed that this implementation is present on the latest Nightly Nightly 65.0a1(2018-11-22)and the latest Beta 64.0b11 as well .
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.