Closed Bug 1458193 Opened 2 years ago Closed 2 years ago

Crash in @0x0 | framework2.odex@0x2d253f

Categories

(Core :: Gecko Profiler, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: calixte, Assigned: m_kato)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-58fc9e40-fd48-4f2d-ad11-8eb3b0180501.
=============================================================

Top 10 frames of crashing thread:

0  @0x0 
1 framework2.odex framework2.odex@0x2d253f 
2 dalvik-mark-stack (deleted) dalvik-mark-stack @0x2f5f24d 
3 dalvik-heap (deleted) dalvik-heap @0x1eb7c461 
4 dalvik-heap (deleted) dalvik-heap @0x1eb78a38 
5 dalvik-heap (deleted) dalvik-heap @0x38a8a6e 
6 dalvik-mark-stack (deleted) dalvik-mark-stack @0x2f7f95f 
7 framework2.odex framework2.odex@0x2cd062 
8 dalvik-heap (deleted) dalvik-heap @0x1ed7bd1e 
9 dalvik-heap (deleted) dalvik-heap @0x9af706e 

=============================================================

There are 3 crashes (from 1 installation) in nightly 61 with buildid 20180430100437. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1350500.

[1] https://hg.mozilla.org/mozilla-central/rev?node=81e24b24a789
Flags: needinfo?(m_kato)
Crash Signature: [@ @0x0 | framework2.odex@0x2d253f] → [@ @0x0 | framework2.odex@0x2d253f] [@ @0x0 | dalvik-aux-structure (deleted)@0x553f]
Flags: needinfo?(m_kato)
Flags: needinfo?(m_kato)
Crash Signature: [@ @0x0 | framework2.odex@0x2d253f] [@ @0x0 | dalvik-aux-structure (deleted)@0x553f] → [@ @0x0 | framework2.odex@0x2d253f] [@ @0x0 | dalvik-aux-structure (deleted)@0x553f] [@ @0x0 | AutoObjectMapperFaultyLib::Map]
Assignee: nobody → m_kato
Flags: needinfo?(m_kato)
Ah, failedToMessage may have bug that it doesn't consider aLog is nullptr.
(Now is midnight, so I will work this tomorrow)
Crash Signature: [@ @0x0 | framework2.odex@0x2d253f] [@ @0x0 | dalvik-aux-structure (deleted)@0x553f] [@ @0x0 | AutoObjectMapperFaultyLib::Map] → [@ @0x0 | framework2.odex@0x2d253f] [@ @0x0 | framework2.odex@0x27b53f] [@ @0x0 | framework2.odex@0x12353f] [@ @0x0 | framework2.odex@0x35653f] [@ @0x0 | dalvik-aux-structure (deleted)@0x553f] [@ @0x0 | AutoObjectMapperFaultyLib::Map]
When AutoObjectMapperFaultyLib.Map is failed, this function will call logging function.  So it have to set logging function.  since shared-libraries-linux.cpp  uses LOG macro,  we should use it for failed logging.
Attachment #8972494 - Flags: review?(jseward)
Comment on attachment 8972494 [details] [diff] [review]
Add logging when AutoObjectMapperFaultyLib is failed

Looks OK to me.
Attachment #8972494 - Flags: review?(jseward) → review+
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9bcae3bf5ca
Add logging when AutoObjectMapperFaultyLib is failed. r=jseward
https://hg.mozilla.org/mozilla-central/rev/e9bcae3bf5ca
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.