Closed Bug 1458220 Opened 3 years ago Closed 1 year ago

don't "always load app dir add-ons irrespective of enabledScopes"

Categories

(Toolkit :: Add-ons Manager, defect, P3)

61 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1525762

People

(Reporter: jesus.christus, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

https://bugzilla.mozilla.org/show_bug.cgi?id=1191468 changed enabledScopes to exclude the app dir because it broke the default theme.
Thanks to https://bugzilla.mozilla.org/show_bug.cgi?id=1372694 the default theme is no longer in that folder and the change to enabledScopes can be reverted.
Since I don't have to much knowledge in this area, I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Priority: -- → P2
What I originally asked for was fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1461127 but I'd like to change this bug to fix something else instead...

If enabledScopes should work as expected and according to the documentation, the scope in the following line should be changed to AddonManager.SCOPE_APPLICATION:

[BuiltInLocation, KEY_APP_SYSTEM_DEFAULTS, AddonManager.SCOPE_PROFILE, KEY_APP_FEATURES, []]

that line is currently @ https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1825-1826

AddonManager.SCOPE_PROFILE is correct for the 2 arrays above (XPIProvider.jsm#1819 + #1822), namely KEY_APP_PROFILE in KEY_PROFILEDIR (=installed extensions in the profile dir) and KEY_APP_SYSTEM_ADDONS in KEY_PROFILEDIR (=updated system addons installed in the profile dir) but is just wrong for KEY_APP_SYSTEM_DEFAULTS in KEY_APP_FEATURES because this is clearly not SCOPE_PROFILE (= "Installed in this profile.").

The enabledScopes is a hidden pref anyway and making it work correctly won't affect the large majority of users but for those few who want to use it, it should match what the description @ https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/AddonManager.jsm#3227-3228 actually says ie SCOPE_PROFILE = "Installed in this profile."

Thanks
Flags: needinfo?(mixedpuppy)
Priority: P2 → P3

The issue in comment 2 was fixed in bug 1525762

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mixedpuppy)
Resolution: --- → DUPLICATE
Duplicate of bug: 1525762
You need to log in before you can comment on or make changes to this bug.