Closed Bug 1458260 Opened 4 years ago Closed 4 years ago

in Dropbox Paper, indenting a bullet list doesn't work

Categories

(Web Compatibility :: Desktop, defect, P1)

defect

Tracking

(firefox59 unaffected, firefox60 affected, firefox61 affected)

RESOLVED FIXED
Tracking Status
firefox59 --- unaffected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: nmatsakis, Unassigned)

References

()

Details

(Whiteboard: [sitewait])

In DropBox paper, when you press TAB to indent a list item in FF nightly (61.0a1 (2018-04-30), nothing happens. It does work in FF 59.0.1 (tested). It also works in Chrome.

Here is a sample document, which includes instructions for how to test the bug:

https://paper.dropbox.com/doc/firefox-bug-vF33DFyOsczJ8ZaZvOIuV
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (59.0.3) and the latest Nightly (61.0a1-20180501220047) and managed to reproduce the issue.

When opening the provided link in the latest Nightly and going in a list, when pressing the "TAB" key nothing happens. The issue is not reproducible on latest Release.

I've performed a regression, here are the results:

Last good revision: 61bbd00bee83d35bfa6d14a5e92f76f5d2150c9f
First bad revision: eb86519cc44fe0d2b64eed8363d7ff36bdbc1499
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=61bbd00bee83d35bfa6d14a5e92f76f5d2150c9f&tochange=eb86519cc44fe0d2b64eed8363d7ff36bdbc1499

Masayuki, can you please have a look upon this issue?
Component: Untriaged → DOM: Events
Flags: needinfo?(masayuki)
Product: Firefox → Core
Priority: -- → P3
This is bug of Dropbox. Do we know a person of Dropbox who can handle this?
Component: DOM: Events → Desktop
Flags: needinfo?(masayuki)
Product: Core → Tech Evangelism
As far as I tested briefly, shortcut keys in the main page works fine.
https://paper.dropbox.com/

Perhaps, only some shortcut keys in the editor are broken. For example, Ctrl + B to bold the text works fine.
(In reply to Masayuki Nakano [:masayuki] (JST, +0900) (away: 4/28 - 5/6) from comment #2)
> This is bug of Dropbox. Do we know a person of Dropbox who can handle this?

Adam, do we have Dropbox contacts?

https://www.fxsitecompat.com/docs/2018/non-printable-keys-will-soon-stop-firing-keypress-event/ would be helpful for them.
Flags: needinfo?(astevenson)
Priority: P3 → P1
Now, paper.dropbox.com/doc is now in our blacklist ("dom.keyboardevent.keypress.hack.dispatch_non_printable_keys" in about:config). Therefore, you cannot reproduce this bug with Nightly unless you remove the URI from the blacklist. Note that the blacklist won't ride the train. So, Dropbox needs to fix this bug by their side anyway.
Mentioned this issue in the site compatibility note.
We have a mailing list with Dropbox, sent an email about this issue.
Flags: needinfo?(astevenson)
Whiteboard: [sitewait]
They are looking into the issue.
They have landed a potential fix for this issue, it is enabled for Firefox 62.

If we remove paper.dropbox.com from the ”dom.keyboardevent.keypress.hack.dispatch_non_printable_keys” config value then keyboard shortcuts including tab indent should work.

:nmatsakis - would you mind confirming this works please?
Flags: needinfo?(nmatsakis)
If it helps, I removed paper.dropbox.com from the mentioned config value and paper ceased to work. Adding it back to the config and reloading returned indenting functionality to the expected behaviour.

Firefox version: 62.0a1 (2018-05-16) (64-bit)
Thanks eddyrox1. It's also not working for me in Firefox Nightly 62.0a1 (2018-05-23) (64-bit) for MacOS after removing paper.dropbox.com from the blacklist.
Flags: needinfo?(nmatsakis)
This is now working as expected in Firefox Nightly 62 after removing paper.dropbox.com from the blacklist.
Per comment 12, and I also checked it.

-> FIXED
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.