Implement Console.timeLog(optional DOMString label = "default")

RESOLVED FIXED in Firefox 62

Status

()

enhancement
P3
normal
RESOLVED FIXED
Last year
3 months ago

People

(Reporter: baku, Assigned: baku)

Tracking

({dev-doc-needed})

58 Branch
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Priority: -- → P3
Assignee

Comment 1

Last year
Posted patch timeLog.patch (obsolete) — Splinter Review
The issue is still open. Probably this patch will require some changes.
Attachment #8972525 - Flags: review?(bgrinstead)
Comment on attachment 8972525 [details] [diff] [review]
timeLog.patch

Review of attachment 8972525 [details] [diff] [review]:
-----------------------------------------------------------------

Nice and simple, looks good to me. Before landing anything, let's wait for the spec issue to be resolved on github since it sounds like it may still change. And then also we need to build the frontend for the feature (should be pretty easy - we can handle it here or in another bug as long as we are sure it'll ship in the same release as this).
Attachment #8972525 - Flags: review?(bgrinstead) → review+
Assignee

Comment 3

Last year
Posted patch timeLog.patchSplinter Review
Here a patch that implements console.timeLog("foo", any) as I suggested on github. If you like this patch, I think it's time to land it.
Attachment #8972525 - Attachment is obsolete: true
Attachment #8974316 - Flags: review?(bgrinstead)
Comment on attachment 8974316 [details] [diff] [review]
timeLog.patch

Review of attachment 8974316 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/console/tests/test_timer.html
@@ +73,5 @@
> +           ("error" in obj.timer);
> +  });
> +  console.timeLog('test');
> +  await cl;
> +  ok(true, "Console.time with error received!");

Nit: "Console.timeLog" instead of "Console.time".
Attachment #8974316 - Flags: review?(bgrinstead) → review+

Comment 5

Last year
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3facc042d321
Implement Console.timeLog(optional DOMString label = "default"), r=bgrins

Comment 6

Last year
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e42c3ae89de0
Implement Console.timeLog(optional DOMString label = "default") - fixed an intermittent failure, r=me

Comment 7

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/3facc042d321
https://hg.mozilla.org/mozilla-central/rev/e42c3ae89de0
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.