Closed Bug 1458783 Opened Last year Closed Last year

Intermittent dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl - got 6, expected 18

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: botond)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:product])

Attachments

(1 file)

Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=176689535&repo=autoland

https://queue.taskcluster.net/v1/task/FFZRQ1jwQjSfgz2jZlaRxA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-03T02:52:07.905Z] 02:52:07     INFO - TEST-START | dom/events/test/test_bug574663.html
[task 2018-05-03T02:52:08.535Z] 02:52:08     INFO - TEST-INFO | started process screentopng
[task 2018-05-03T02:52:09.311Z] 02:52:09     INFO - TEST-INFO | screentopng: exit 0
[task 2018-05-03T02:52:09.315Z] 02:52:09     INFO - Buffered messages logged at 02:52:08
[task 2018-05-03T02:52:09.315Z] 02:52:09     INFO - must wait for load
[task 2018-05-03T02:52:09.315Z] 02:52:09     INFO - must wait for focus
[task 2018-05-03T02:52:09.316Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling shouldn't change zoom 
[task 2018-05-03T02:52:09.316Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling should scroll 
[task 2018-05-03T02:52:09.317Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling shouldn't change zoom, even after releasing the touchpad 
[task 2018-05-03T02:52:09.318Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling should scroll, even after releasing the touchpad 
[task 2018-05-03T02:52:09.320Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Ctrl-scrolling should zoom while the user is touching the touchpad 
[task 2018-05-03T02:52:09.321Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Ctrl-scrolling shouldn't scroll while the user is touching the touchpad 
[task 2018-05-03T02:52:09.326Z] 02:52:09     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Momentum scrolling shouldn't zoom, even when pressing Ctrl 
[task 2018-05-03T02:52:09.327Z] 02:52:09     INFO - Buffered messages finished
[task 2018-05-03T02:52:09.329Z] 02:52:09     INFO - TEST-UNEXPECTED-FAIL | dom/events/test/test_bug574663.html | Momentum scrolling should scroll, even when pressing Ctrl - got 6, expected 18
Botond, this fails frequently and looks like fallout from bug 1458063. Please investigate or let us know if it shall get backed out.
Flags: needinfo?(botond)
Assignee: nobody → botond
Flags: needinfo?(botond)
Blocks: 1458063
Bisection is showing that the intermittent failure is caused by the first patch from bug 1458063. As it happens, that patch is not actually necessarily to accomplish the goals of bug 1458063 (see bug 1458063 comment 17).

I'd like to investigate some more to better understand _why_ that patches causes the intermittent (as it's not clear to me), but we can start by backing it out for now.
Comment on attachment 8973300 [details]
Bug 1458783 - Back out the first patch in bug 1458063 (propagate wheel event modifiers in APZInputBridge::ReceiveInputEvent).

https://reviewboard.mozilla.org/r/241774/#review247640
Attachment #8973300 - Flags: review?(bugmail) → review+
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1120a82a5604
Back out the first patch in bug 1458063 (propagate wheel event modifiers in APZInputBridge::ReceiveInputEvent). r=kats
https://hg.mozilla.org/mozilla-central/rev/1120a82a5604
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Whiteboard: [stockwell needswork:owner] → [stockwell fixed:product]
See Also: → 1523824
You need to log in before you can comment on or make changes to this bug.