Closed Bug 1458821 Opened Last year Closed Last year

Rename nsIAsyncFileMetadata.asyncWait to asyncFileMetadataWait

Categories

(Core :: DOM: File, enhancement)

58 Branch
enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: baku, Assigned: baku)

Details

Attachments

(1 file)

This was discussed in bug 1434553.
Attached patch fs_0.patchSplinter Review
Attachment #8972808 - Flags: review?(bugs)
Comment on attachment 8972808 [details] [diff] [review]
fs_0.patch

Not sure which one is better, 
asyncFileMetadataWait or asyncWait(For)FileMetadata.
I guess it depends on the naming convention elsewhere.
Attachment #8972808 - Flags: review?(bugs) → review+
(In reply to Olli Pettay [:smaug] from comment #2)
> Not sure which one is better, 
> asyncFileMetadataWait or asyncWait(For)FileMetadata.
> I guess it depends on the naming convention elsewhere.

asyncWait(For)FileMetadata has the advantage that a naive searchfox query for "asyncWait" will find both it and the normal "asyncWait" symbol.
hmm, that might be actually a disadvantage. the method is quite different to the normal asyncWait
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c07fc14c5821
Rename nsIAsyncFileMetadata.asyncWait to asyncFileMetadataWait, r=smaug
https://hg.mozilla.org/mozilla-central/rev/c07fc14c5821
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.