A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked

VERIFIED FIXED in Firefox -esr60

Status

()

P1
normal
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: mcoman, Assigned: rrosario)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 61
Unspecified
All
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(relnote-firefox 60+, firefox-esr6060+ verified, firefox59 unaffected, firefox60+ verified, firefox61 verified, firefox62 verified)

Details

Attachments

(3 attachments)

Posted image rec of the issue.gif
[Affected versions]:
- Firefox Beta 60.0b16
- Nightly 61.0a1

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new Firefox profile.
- Have the set-up for the "Title 1" variant configured (https://goo.gl/cL4Ue3).

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites.
2. Open two new tabs and click the "Customize your New Tab page" button from the top right part of the page.
3. Uncheck the "Sponsored Stories" option.
4. Open a new tab and observe the "Recommended by Pocket" area.

[Expected result]:
- Only the "Pocket" recommendations cards are displayed.

[Actual results]:
- A "Sponsored content" card is also displayed.

[Additional Notes]:
- The issue is reproducible for all the variants except "Control".
- This issue is no longer reproducible for the next new tabs opened.
- Attached a screen recording of the issue.
Component: Shield Study → Activity Streams: Newtab
Product: Shield → Firefox

Updated

11 months ago
Assignee: nobody → rrosario
Iteration: --- → 61.4 - May 7
Priority: -- → P1

Comment 2

11 months ago
Hi Julien, Tim pinged me about this one. It is a potential RC3 build driver/ride-along.
Flags: needinfo?(jcristau)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED

Updated

11 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (mozreview-request)

Comment 6

11 months ago
mozreview-review
Comment on attachment 8973041 [details]
Bug 1458906 - A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked

https://reviewboard.mozilla.org/r/241576/#review247392

Thanks, looks good
Attachment #8973041 - Flags: review?(khudson) → review+

Comment 7

11 months ago
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4750a81367f3
A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked r=k88hudson

Comment 8

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4750a81367f3
Status: REOPENED → RESOLVED
Last Resolved: 11 months ago11 months ago
status-firefox61: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
:cmarius, the decision has been made that this bug isn't a driver for RC3, but should ride along if an RC3 becomes necessary.  Could you take another look at the fix that landed in Nightly and verify?
Flags: needinfo?(jcristau) → needinfo?(marius.coman)
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Firefox: 61.0a1, Build ID 20180504100129

I have verified the fix for this issue and I can confirm that is no longer reproducible on Windows 10 x64, Mac 10.13 and Ubuntu 14.04 x64 with the latest Nightly build (61.0a1) installed. 
Now, the "Sponsored content" is no longer displayed after it was disabled from the "about:preferences" page. 

However, keep in mind that if there won't be an RC3 build for Beta 60, this issue will soon affect the Firefox Release population that will be enrolled in the "Pocket Spocs Optimization Test" shield study, since the Fx60 is planned to be launched on May 9th.
status-firefox61: fixed → verified
Flags: needinfo?(marius.coman)

Comment 11

11 months ago
Comment on attachment 8973041 [details]
Bug 1458906 - A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked

Approval Request Comment
[Feature/Bug causing the regression]: Pocket sponsored content
[User impact if declined]: Sponsored content stays visible on the first new tab after turning it off
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes comment 10
[Needs manual test from QE? If yes, steps to reproduce]: For a rc? probably good to. Steps in comment 0
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: A little
[Why is the change risky/not risky?]: Brand new code to fix the bug, but it's similar to the user just normally turning the section off and on again.
[String changes made/needed]: None
Attachment #8973041 - Flags: approval-mozilla-release?
Any chance we want to reconsider an uplift, given recent articles such as https://www.theverge.com/2018/5/7/17326184/firefox-ads-sponsored-content-pocket-suggestions

I understand that this may not affect a huge number of users, but displaying sponsored content to people who _just_ disabled it may make a few people confused/angry.
I tried to reproduce the bug using an older version of Nightly 61.0a1 (2018-05-03) on Windows 10 x64 by following the steps from comment 0 and from https://goo.gl/cL4Ue3, but I didn't get any Sponsored Stories in the Recommended by Pocket section. 

In the browser console there were thrown two errors that could explain why this happens:
 [Show/hide message details.] TelemetryStopwatch: key "TELEMETRY_PENDING_LOAD_MS" was already initialized

 [Show/hide message details.] TelemetryStopwatch: requesting elapsed time for nonexisting stopwatch. Histogram: "TELEMETRY_PENDING_LOAD_MS", key: "null"

Can you please give me some information about how can I verify this or at least to force the Sponsored Stories to appear?
Flags: needinfo?(rrosario)
(Assignee)

Comment 14

11 months ago
(In reply to Oana Botisan from comment #13)
> Can you please give me some information about how can I verify this or at
> least to force the Sponsored Stories to appear?

For manual testing:
1- Save this file locally: https://www.dropbox.com/s/03u5m579hzsvznh/spocs.json
2- Go to about:config, and edit "browser.newtabpage.activity-stream.feeds.section.topstories.options" so that "stories_endpoint" is pointing to your local file ("file:///..../spocs.json")
3- Make sure "browser.newtabpage.activity-stream.showSponsored" is set to true as well.

That should do it.
Flags: needinfo?(rrosario)
I managed to reproduce the issue on an older version of Nightly (2018-05-03) using Windows 10 x64 and the steps from comment 14.
I retested everything using the latest Nightly 62.0a1 and beta 61.0b4 on Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.13. The bug is not reproducing anymore.
Status: RESOLVED → VERIFIED
status-firefox62: --- → verified
Flags: qe-verify+
Comment on attachment 8973041 [details]
Bug 1458906 - A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked

Fix an issue when disabling sponsored content, approved for 60.0.1
Attachment #8973041 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 17

11 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/540ffec9584e
status-firefox60: affected → fixed
Flags: in-testsuite+
Comment on attachment 8973041 [details]
Bug 1458906 - A "Sponsored content" card is wrongly displayed on the first new tab opened, after the "Sponsored Stories" option was unchecked

actually let's get this one on esr60 too, in the interest of keeping release and esr60 in sync this cycle.
Attachment #8973041 - Flags: approval-mozilla-esr60+
status-firefox-esr60: --- → fix-optional
tracking-firefox60: --- → +
tracking-firefox-esr60: --- → 60+
Flags: qe-verify+

Comment 19

11 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr60/rev/423e30150b9a
status-firefox-esr60: fix-optional → fixed
Added it to Firefox and ESR 60.0.1 release notes.
relnote-firefox: --- → 60+
Verified the fix on Firefox 60.0.1 and ESR 60.0.1 using Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.13. The bug is not reproducing anymore.
status-firefox60: fixed → verified
status-firefox-esr60: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.