Closed Bug 1458977 Opened 4 years ago Closed 4 years ago

Crash in nsFloatManager::ImageShapeInfo::ImageShapeInfo

Categories

(Core :: Layout: Floats, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: marcia, Assigned: bradwerth)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-7d63baf7-7cfa-40e4-9407-a60b10180502.
=============================================================

Seen while looking at nightly crash stats - so far very small volume crash hitting Mac and Windows: https://bit.ly/2HN5pta.

looks as if :bradwerth worked in this area in 61, adding ni on him. 

Top 10 frames of crashing thread:

0 xul.dll nsFloatManager::ImageShapeInfo::ImageShapeInfo layout/generic/nsFloatManager.cpp:1693
1 xul.dll mozilla::MakeUnique<nsFloatManager::ImageShapeInfo, unsigned char*&, int&, mozilla::gfx::IntSizeTyped<mozilla::LayoutDevicePixel>&, int&, float&, int&, nsRect&, nsRect&, mozilla::WritingMode&, nsSize const&> mfbt/UniquePtr.h:680
2 xul.dll nsFloatManager::ShapeInfo::CreateImageShape layout/generic/nsFloatManager.cpp:2431
3 xul.dll nsFloatManager::FloatInfo::FloatInfo layout/generic/nsFloatManager.cpp:1975
4 xul.dll nsFloatManager::AddFloat layout/generic/nsFloatManager.cpp:260
5 xul.dll mozilla::BlockReflowInput::FlowAndPlaceFloat layout/generic/BlockReflowInput.cpp:994
6 xul.dll mozilla::BlockReflowInput::PlaceBelowCurrentLineFloats layout/generic/BlockReflowInput.cpp:1083
7 xul.dll nsBlockFrame::PlaceLine layout/generic/nsBlockFrame.cpp:4687
8 xul.dll nsBlockFrame::DoReflowInlineFrames layout/generic/nsBlockFrame.cpp:4086
9 xul.dll nsBlockFrame::ReflowInlineFrames layout/generic/nsBlockFrame.cpp:3832

=============================================================
Flags: needinfo?(bwerth)
This should be resolved by the patch that landed for Bug 1457288.
No reports since bug 1457288 landed, which is good enough for me to say it's fixed.
Assignee: nobody → bwerth
Status: NEW → RESOLVED
Closed: 4 years ago
Depends on: 1457288
Flags: needinfo?(bwerth)
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.